Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-14-2014, 07:54 PM   #251
MassBugeye
Scooby Specialist
 
Member#: 359347
Join Date: Jun 2013
Chapter/Region: NESIC
Location: Tewksbury, MA
Vehicle:
2002 WRX
PSM

Default

Yes I can see the picture. But thats pretty impressive for a 12+ year old car! I too drive a Bugeye but it feels like I barely broke it in since Im a little under 165K and you are at 236K! I guess I cant be worried about the longevity of my car at this point.

Anyways, you have an awesome car and good luck with it! I'll be looking forward to seeing what you do next.
* Registered users of the site do not see these ads.
MassBugeye is offline   Reply With Quote
Old 04-15-2014, 12:07 PM   #252
benit0
Scooby Newbie
 
Member#: 202204
Join Date: Feb 2009
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
02 WRX
PSM

Default

Thanks! Hopefully it stays consistent and puts down good numbers on May 31st... and not blow up.
benit0 is offline   Reply With Quote
Old 04-15-2014, 01:19 PM   #253
ScooobaSeth
Scooby Newbie
 
Member#: 165607
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
04 Wagon
Holset Powered

Default

260k on my rotated holset ej205 all original.....keeps on going up up up
ScooobaSeth is offline   Reply With Quote
Old 04-25-2014, 12:27 AM   #254
Chadetroit
Scooby Newbie
 
Member#: 388550
Join Date: Apr 2014
Default

Had 200k on my 03 wagon. Was a great ride and barely ever gave me a problem. First clutch at 160k. Re invested in a 2011 wry wagon and couldn't be happier with the improvements they made. Looking forward to pulling this one to 200k
Chadetroit is offline   Reply With Quote
Old 04-25-2014, 04:01 AM   #255
Saabaru300
Scooby Specialist
 
Member#: 334105
Join Date: Oct 2012
Chapter/Region: MWSOC
Location: Southeast Michigan
Vehicle:
2005 Saab 9-2x Aero
Red

Default

Have a friend with a 04 wrx wagon. It has about 250k miles on it. The motor only as 100k though. He bought the car broken with 210k miles, spun bearing because of driver error. The trans is a little trouble some but with some care, it works just fine.
Saabaru300 is online now   Reply With Quote
Old 04-25-2014, 12:48 PM   #256
Project_broke
Scooby Newbie
 
Member#: 384000
Join Date: Mar 2014
Location: Indianapolis
Vehicle:
2002 Wrx wagon
Wrb

Default

Just rolled over 270k on my wagon. The cats just died on me, everything has been stock this long.
Project_broke is offline   Reply With Quote
Old 04-25-2014, 02:37 PM   #257
PassinThrough
Scooby Newbie
 
Member#: 350612
Join Date: Mar 2013
Location: California
Vehicle:
2004 WRX Wagon
WRB

Default

172 in my 04 wagon... She's gettin there!
PassinThrough is online now   Reply With Quote
Old 04-25-2014, 02:43 PM   #258
NJReppin
Scooby Newbie
 
Member#: 371530
Join Date: Oct 2013
Chapter/Region: Tri-State
Location: (856),New Jersey
Vehicle:
2004 2.5rs
pacifica blue pearl

Default

Tell me if I'm crazy for turning this deal down... 02 sedan with 294k on the dash... owner claims engine was just rebuilt ~ 3,000 miles ago and previous owner did tranny supposedly... could not provide me with any receipts though and the ad claimed the car had 145k, when I asked about it he said the previous owner told him it was read in KMs?

wouldn't go any lower than 5k for it...
NJReppin is offline   Reply With Quote
Old 04-25-2014, 03:01 PM   #259
cmiovino
Scooby Guru
 
Member#: 134005
Join Date: Dec 2006
Chapter/Region: MAIC
Location: Pittsburgh, PA
Vehicle:
2004 WRX Premium
PSM

Default

Quote:
Originally Posted by NJReppin View Post
Tell me if I'm crazy for turning this deal down... 02 sedan with 294k on the dash... owner claims engine was just rebuilt ~ 3,000 miles ago and previous owner did tranny supposedly... could not provide me with any receipts though and the ad claimed the car had 145k, when I asked about it he said the previous owner told him it was read in KMs?

wouldn't go any lower than 5k for it...
For $5k, he better have all documentation for the engine, tranny, etc.

He can't just 'claim' it was done. Why do people not save receipts for thousands of dollars? I save all mod/maintenance receipts. Goes with the car when sold.

He's BSing you.
cmiovino is offline   Reply With Quote
Old 04-26-2014, 12:54 AM   #260
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by NJReppin View Post
Tell me if I'm crazy for turning this deal down... 02 sedan with 294k on the dash... owner claims engine was just rebuilt ~ 3,000 miles ago and previous owner did tranny supposedly... could not provide me with any receipts though and the ad claimed the car had 145k, when I asked about it he said the previous owner told him it was read in KMs?

wouldn't go any lower than 5k for it...

not worth $5k
Uncle Scotty is offline   Reply With Quote
Old 04-26-2014, 11:02 AM   #261
Maine-Subie
Scooby Newbie
 
Member#: 381389
Join Date: Feb 2014
Chapter/Region: NESIC
Location: Lyman, Maine
Vehicle:
2003 Impreza WRX
Silver

Default

202,000 miles on my 2003 wagon, still going strong.
Maine-Subie is offline   Reply With Quote
Old 04-26-2014, 12:52 PM   #262
ogboot
Scooby Specialist
 
Member#: 170906
Join Date: Feb 2008
Chapter/Region: South East
Vehicle:
2002 WRX
psm

Default

Mine was going strong with a 16G, but at 193k I popped a coolant hose, overheated, and spun a bearing.

Now it's not the DD anymore
ogboot is offline   Reply With Quote
Old 07-30-2014, 04:03 PM   #263
4eat05
Scooby Newbie
 
Member#: 378421
Join Date: Jan 2014
Location: NC
Vehicle:
2005 Cobb Stg2+ Wrx
Platinum Silver

Default

Man this thread makes me feel much better! lol

Just rolled 132k on my stg2 '05 Wrx. Was always worried I would never see 200k, but now there is hope !
4eat05 is offline   Reply With Quote
Old 07-31-2014, 12:50 AM   #264
blakkboxer
Scooby Guru
 
Member#: 167244
Join Date: Dec 2007
Chapter/Region: TXIC
Location: DFW, Tx
Vehicle:
2k3 WRX MBP
black & gold is pimpin'

Default

197k here and still going!
blakkboxer is online now   Reply With Quote
Old 07-31-2014, 09:01 AM   #265
shamrock 05
Scooby Guru
 
Member#: 120057
Join Date: Jul 2006
Chapter/Region: MWSOC
Location: *outskirts of motor city*
Vehicle:
2004 "Bugeye" WRX
WRB

Default

Quote:
Originally Posted by NJReppin View Post
Tell me if I'm crazy for turning this deal down... 02 sedan with 294k on the dash... owner claims engine was just rebuilt ~ 3,000 miles ago and previous owner did tranny supposedly... could not provide me with any receipts though and the ad claimed the car had 145k, when I asked about it he said the previous owner told him it was read in KMs?

wouldn't go any lower than 5k for it...
I would not have bought that car with the previous owner saying he has "no receipts" F that.....if you spent that much money....prove it to me

Quote:
Originally Posted by blakkboxer View Post
197k here and still going!
The black paints holding up well, car looks good man.
shamrock 05 is offline   Reply With Quote
Old 07-31-2014, 09:40 AM   #266
blakkboxer
Scooby Guru
 
Member#: 167244
Join Date: Dec 2007
Chapter/Region: TXIC
Location: DFW, Tx
Vehicle:
2k3 WRX MBP
black & gold is pimpin'

Default

Quote:
Originally Posted by shamrock 05 View Post



The black paints holding up well, car looks good man.
The car got repainted last year.
blakkboxer is online now   Reply With Quote
Old 08-01-2014, 11:14 AM   #267
shamrock 05
Scooby Guru
 
Member#: 120057
Join Date: Jul 2006
Chapter/Region: MWSOC
Location: *outskirts of motor city*
Vehicle:
2004 "Bugeye" WRX
WRB

Default

Quote:
Originally Posted by blakkboxer View Post
The car got repainted last year.
Well that works too
shamrock 05 is offline   Reply With Quote
Old 08-09-2014, 09:10 AM   #268
yosemitemtb
Scooby Specialist
 
Member#: 23437
Join Date: Aug 2002
Chapter/Region: BAIC
Location: Yosemite
Vehicle:
'02 WRX Wagon
WR Blue Pearl

Default

177,000 on my '02, half of those with a vf39, the other half at stage 2. I've done hundreds of autocross runs over 12 years, and a few track days. I had a spun rod bearing just before 100k, put in a new shortblock and clutch then. Should have done the heads at the same time, burned an exhaust valve last winter at 170k. New valves, reinstalled the td04 (I like STX more than SM at the autoX) and another new clutch just because the motor was out and I'm ready for another 177k. One thing when pulling the motor this time, lots of the plastic bits are getting brittle. I replaced just about every vacuum line and connector. Otherwise, regular oil changes for the motor and gear boxes, front wheel bearings, front axles a couple of times and wear items like brake discs have come up. This hasn't been a cheap car to keep up, but it still puts a smile on my face when my foot hits the go pedal.

Last edited by yosemitemtb; 08-09-2014 at 09:16 AM.
yosemitemtb is offline   Reply With Quote
Old 08-12-2014, 08:44 PM   #269
Awd180
Scooby Newbie
 
Member#: 282763
Join Date: May 2011
Chapter/Region: Tri-State
Location: USA
Vehicle:
2002 Impreza
Gray

Default

I have ~175k, bought it w/ 140k on it. I've put in a used trans and front axles at 160k, some minor other fixes. Had the a serious brake issue still not resolved and I need to work out some vibration issue above 70mph. I believe its either worn suspension parts or engine and trans mounts. Timing belts due soon, but as long as I can keep the car from rusting away or blowing the head off I'm gonna drive it. Might even take it to that point so I can drop in a newer motor.


Sent from my iPhone using NASIOC
Awd180 is offline   Reply With Quote
Old 08-12-2014, 11:15 PM   #270
Ballfade
Scooby Newbie
 
Member#: 363062
Join Date: Jul 2013
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2002 WRX
WRB

Default

Quote:
Originally Posted by Awd180 View Post
I have ~175k, bought it w/ 140k on it. I've put in a used trans and front axles at 160k, some minor other fixes. Had the a serious brake issue still not resolved and I need to work out some vibration issue above 70mph. I believe its either worn suspension parts or engine and trans mounts. Timing belts due soon, but as long as I can keep the car from rusting away or blowing the head off I'm gonna drive it. Might even take it to that point so I can drop in a newer motor.


Sent from my iPhone using NASIOC
Make sure to check out your driveshaft on the vibration issue, mines started the same way.
Ballfade is offline   Reply With Quote
Old 08-13-2014, 12:42 AM   #271
yosemitemtb
Scooby Specialist
 
Member#: 23437
Join Date: Aug 2002
Chapter/Region: BAIC
Location: Yosemite
Vehicle:
'02 WRX Wagon
WR Blue Pearl

Default

My advice to high mile WRX owners is to not neglect your valve adjustment.
yosemitemtb is offline   Reply With Quote
Old 08-13-2014, 03:05 PM   #272
gtbensley
Scooby Specialist
 
Member#: 167448
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Kittery Maine
Vehicle:
2013 2013 wrx hatch
Plasma blue pearl

Default

People still do those?
gtbensley is offline   Reply With Quote
Old 08-13-2014, 03:36 PM   #273
yosemitemtb
Scooby Specialist
 
Member#: 23437
Join Date: Aug 2002
Chapter/Region: BAIC
Location: Yosemite
Vehicle:
'02 WRX Wagon
WR Blue Pearl

Default

Quote:
Originally Posted by gtbensley View Post
People still do those?

You don't have to if you don't mind pulling the motor and spending a bunch of money replacing valves.
yosemitemtb is offline   Reply With Quote
Old 08-14-2014, 12:21 AM   #274
Awd180
Scooby Newbie
 
Member#: 282763
Join Date: May 2011
Chapter/Region: Tri-State
Location: USA
Vehicle:
2002 Impreza
Gray

Default

Quote:
Originally Posted by Ballfade View Post
Make sure to check out your driveshaft on the vibration issue, mines started the same way.

Did you go with oem or upgrade I've been thinking of an aluminum.


Sent from my iPhone using NASIOC
Awd180 is offline   Reply With Quote
Old 08-14-2014, 01:00 AM   #275
Ballfade
Scooby Newbie
 
Member#: 363062
Join Date: Jul 2013
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2002 WRX
WRB

Default

I just put a oem one. Got it for 135 on ebay, came off a 06.

Last edited by Ballfade; 08-14-2014 at 01:06 AM.
Ballfade is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
high mileage WRX? l0s3r421 Service & Maintenance 5 01-14-2003 04:47 PM
high mileage WRX @ dealers HekWRX General Community 19 01-01-2002 05:49 AM
high mileage WRX @ dealers HekWRX Texas Impreza Club Forum -- TXIC 15 12-30-2001 10:50 AM


All times are GMT -4. The time now is 09:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.