Welcome to the North American Subaru Impreza Owners Club Monday September 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-19-2014, 06:12 PM   #1
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default Id1000 injectors o-ring random leak ?

So I haven't driven my car since last yr.. Today decide take it around the block
Anyways I smelled gas pulled over see the injector pissing out gas

I noticed it coming from one of the o-rings

So could it possible dried out or it's just not in correctly

I drove around all last yr was fine

Any input be great thxs
* Registered users of the site do not see these ads.
gtasti is offline   Reply With Quote
Old 06-19-2014, 06:36 PM   #2
JAMM0N
Scooby Specialist
 
Member#: 318736
Join Date: May 2012
Chapter/Region: MWSOC
Location: Milwaukee, WI
Vehicle:
2013 WRX Hatch
CBS (BLCK)

Default

could've seated wrong or actually tore. or pressure building up in the injector made it come loose?

if it comes to that you're going to need a replacement. hopefully your local friends or subaru has O-rings for you, so you can get back on the road. happy hunting
JAMM0N is offline   Reply With Quote
Old 06-19-2014, 06:58 PM   #3
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

I guess I'll have to see what happen when I pull her apart

Thxs
gtasti is offline   Reply With Quote
Old 06-19-2014, 07:27 PM   #4
25rsti
Scooby Guru
 
Member#: 166324
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Haverhill, MA
Vehicle:
3 turbos &n NA
@DBlockSTi

Default

I would order some new o rings (I might even have some left over). Happened to me before (not IDs) but still. Swapped new orings and haven't had a problem since. Cheap insurance.
25rsti is offline   Reply With Quote
Old 06-20-2014, 05:14 PM   #5
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

Yeah I emailed t1 they sending new o-rings got 8 of em
gtasti is offline   Reply With Quote
Old 06-20-2014, 07:16 PM   #6
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

So turns out the fuel rail came loose
gtasti is offline   Reply With Quote
Old 06-21-2014, 05:35 PM   #7
JAMM0N
Scooby Specialist
 
Member#: 318736
Join Date: May 2012
Chapter/Region: MWSOC
Location: Milwaukee, WI
Vehicle:
2013 WRX Hatch
CBS (BLCK)

Default

glad you got it resolved! hey extra o rings ftw. lmao
JAMM0N is offline   Reply With Quote
Old 06-21-2014, 10:01 PM   #8
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

Yea was thinking that double o-ringed
gtasti is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.