Welcome to the North American Subaru Impreza Owners Club Monday October 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-14-2014, 10:17 AM   #651
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

^^^
That information was added to the first page of the sticky a while ago
* Registered users of the site do not see these ads.
RexyGirl is offline   Reply With Quote
Old 07-16-2014, 03:44 PM   #652
Forgiven
Scooby Newbie
 
Member#: 217001
Join Date: Jul 2009
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2005 Impreza
White

Default 2005 and 2006 Impreza wagons

I just got a 2006 wagon and it came without the teardrop key fobs. I do have a matched pair from my previous 2005 model. I put a new battery in one and looked in the manual on how to program it. It said to get the number from inside the fob, this I did. Then it told of the process to program it. Using the 8 digits of that number...The number on my older fobs has one 0 and two letters in it. So it looks like that fob will not work with the newer cars instructions. I then took the instructions for the older fobs and tried doing that with the newer car, no can do. I then saw how I am to reset the fob when a new battery is put in it....click it 6 times, did that and the horn did chirp. So it does talk to the computer. Went through the simple older instructions again and no results. My question is this: Can an older fob a number having 0 and letters in it be used on this newer car that is asking me to hit the lock button the number of times each digit in that code ? Hope this makes enough sense....and Thankyou. Ps. I am having trouble getting any beeps when doing the on/off ignition in less than 15 secs. (thus can not get past that step) I also tried the not going all the way back to Lock position, and that did not work either. Should I take off the battery cable? I am hesitant to do that, don't want other stuff to mess up...does the radio lock if you do that? Thanks again.
Forgiven is offline   Reply With Quote
Old 07-16-2014, 11:50 PM   #653
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Forgiven View Post
I just got a 2006 wagon and it came without the teardrop key fobs. I do have a matched pair from my previous 2005 model. I put a new battery in one and looked in the manual on how to program it. It said to get the number from inside the fob, this I did. Then it told of the process to program it. Using the 8 digits of that number...The number on my older fobs has one 0 and two letters in it. So it looks like that fob will not work with the newer cars instructions. I then took the instructions for the older fobs and tried doing that with the newer car, no can do. I then saw how I am to reset the fob when a new battery is put in it....click it 6 times, did that and the horn did chirp. So it does talk to the computer. Went through the simple older instructions again and no results. My question is this: Can an older fob a number having 0 and letters in it be used on this newer car that is asking me to hit the lock button the number of times each digit in that code ? Hope this makes enough sense....and Thankyou. Ps. I am having trouble getting any beeps when doing the on/off ignition in less than 15 secs. (thus can not get past that step) I also tried the not going all the way back to Lock position, and that did not work either. Should I take off the battery cable? I am hesitant to do that, don't want other stuff to mess up...does the radio lock if you do that? Thanks again.
In order to program a remote into the newer model, it has to have all numbers, no letters (depending on model of vehicle) and vice versa. One will not program to the other. You can't enter a letter when using the 'long' program method.
RexyGirl is offline   Reply With Quote
Old 07-18-2014, 01:31 AM   #654
shane79
Scooby Newbie
 
Member#: 396607
Join Date: Jul 2014
Default

I am having an issue with my 05 STI. I just bought it. The remote is the tear drop with 2 grey buttons. The car does not lock or unlock. at all. I have tried everything you posted. the lights will flash when I hit the unlock button, they will not however flash when I use the Lock button. The security light is on. blink, pause blink. but again, the car doesn't lock at all, no chirps, nothing. Im getting really irritated with it and im ready to drive it off a damn cliff. Someone help me please lol.
shane79 is offline   Reply With Quote
Old 07-18-2014, 01:01 PM   #655
Forgiven
Scooby Newbie
 
Member#: 217001
Join Date: Jul 2009
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2005 Impreza
White

Default

Yeah that is what I was thinking Rexy....and I found that the remote I have was talking to my other car in the garage, not the one I was sitting in! Silly me. Anyway thanks for the quick reply, you are great.
Forgiven is offline   Reply With Quote
Old 07-22-2014, 03:56 PM   #656
adamohurd
Scooby Newbie
 
Member#: 276227
Join Date: Mar 2011
Default

what about pre 2001 vehicles?
adamohurd is offline   Reply With Quote
Old 07-23-2014, 01:16 AM   #657
bobchees3
Scooby Newbie
 
Member#: 338521
Join Date: Nov 2012
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2002 WRX Wagon
Silver

OMGHi2U 2002 wrx remote

My wrx is going through the coding sequence fine but afterwards my remote will only work for about 3 clicks before doing nothing. I'm not sure if it means anything, but the red LED remains lit on the remote. I might just try to get a new one. Should I head to a dealership or get and aftermarket one?
bobchees3 is offline   Reply With Quote
Old 07-23-2014, 12:22 PM   #658
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by shane79 View Post
I am having an issue with my 05 STI. I just bought it. The remote is the tear drop with 2 grey buttons. The car does not lock or unlock. at all. I have tried everything you posted. the lights will flash when I hit the unlock button, they will not however flash when I use the Lock button. The security light is on. blink, pause blink. but again, the car doesn't lock at all, no chirps, nothing. Im getting really irritated with it and im ready to drive it off a damn cliff. Someone help me please lol.
It sounds like your issue is not a remote issue (the lights flash), but a door lock actuator issue.
RexyGirl is offline   Reply With Quote
Old 07-23-2014, 12:26 PM   #659
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by adamohurd View Post
what about pre 2001 vehicles?
If you have a factory keyless / alarm, then programming it requires using the button under the dash on the left side (that usually falls into the dash and has to be located by looking under the dash). Your owners manual shows a picture of where it is located.

With the key in the ON position, you press and hold that button until the door locks cycle 3 times. Then press a button on the remote. Remove the key and the remote should be programmed
RexyGirl is offline   Reply With Quote
Old 07-23-2014, 12:27 PM   #660
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by bobchees3 View Post
My wrx is going through the coding sequence fine but afterwards my remote will only work for about 3 clicks before doing nothing. I'm not sure if it means anything, but the red LED remains lit on the remote. I might just try to get a new one. Should I head to a dealership or get and aftermarket one?
One of the buttons on your remote is sticking. Try opening it up and cleaning it and see if that helps
RexyGirl is offline   Reply With Quote
Old 07-24-2014, 06:30 PM   #661
Forgiven
Scooby Newbie
 
Member#: 217001
Join Date: Jul 2009
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2005 Impreza
White

Default

Yesterday I Went to the auto wreckers and got a transmitter from inside a 2006 Impreza, opened it up and made sure it had a all numbers code. I now have gone through the programing over and over with the same result.....after inputing the code two times over as the manual says there is that last one second beep, but the locks do not cycle on and off as the manual says it will do, indicating the acceptance of the code and locking in of the remote. There is a new battery in the remote, that sort of is not the issue as the computer is not finishing off the loading of the code anyway....not sure how to proceed.
Forgiven is offline   Reply With Quote
Old 07-25-2014, 02:10 PM   #662
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Forgiven View Post
Yesterday I Went to the auto wreckers and got a transmitter from inside a 2006 Impreza, opened it up and made sure it had a all numbers code. I now have gone through the programing over and over with the same result.....after inputing the code two times over as the manual says there is that last one second beep, but the locks do not cycle on and off as the manual says it will do, indicating the acceptance of the code and locking in of the remote. There is a new battery in the remote, that sort of is not the issue as the computer is not finishing off the loading of the code anyway....not sure how to proceed.
What model car do you have?
Check your owners manual and see if you are performing the correct procedure
RexyGirl is offline   Reply With Quote
Old 07-27-2014, 11:33 AM   #663
Forgiven
Scooby Newbie
 
Member#: 217001
Join Date: Jul 2009
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2005 Impreza
White

Default

Rexy I have an Imprezza 2.5i Wagon. I followed the manual instructions to a tee several times. I get the proper beeps right up to the end where the one second beep happens....but no final on and off of the locks to say the remote is programed (this is supposed to happen next). No matter, I took the remote back. If I keep this car I will get a remote starter for it anyway and will not need the stock remote....Thanks.
Forgiven is offline   Reply With Quote
Old 07-27-2014, 02:26 PM   #664
Ilovemyboxer
Scooby Newbie
 
Member#: 379336
Join Date: Jan 2014
Chapter/Region: NESIC
Location: New England
Vehicle:
08 Wrx
Pearl white

Default Factory Alarm/Keyless Entry...All you need to know!!

can you purchase the remote anywhere other than the dealer? And can the trunk be opened from the remote?
Ilovemyboxer is offline   Reply With Quote
Old 07-27-2014, 05:58 PM   #665
Forgiven
Scooby Newbie
 
Member#: 217001
Join Date: Jul 2009
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2005 Impreza
White

Default

I found some on Ebay, but sellers I contacted could not assure me I would get one with an all numeric code. As I said I found the one I had at an auto wreckers. Yes I saw remotes on Ebay that had a trunk release button.
Forgiven is offline   Reply With Quote
Old 07-29-2014, 02:01 PM   #666
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Ilovemyboxer View Post
can you purchase the remote anywhere other than the dealer? And can the trunk be opened from the remote?
Remotes can be purchased elsewhere....but you get what you pay for and sometimes they send you the wrong remote because they look similar.

The new replacement remotes have a trunk button on them, but that's not what its used for. Its used to put the alarm in valet mode. If you didn't have the option to pop the trunk before, you won't now with the updated remote.
RexyGirl is offline   Reply With Quote
Old 07-29-2014, 02:06 PM   #667
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Forgiven View Post
Rexy I have an Imprezza 2.5i Wagon. I followed the manual instructions to a tee several times. I get the proper beeps right up to the end where the one second beep happens....but no final on and off of the locks to say the remote is programed (this is supposed to happen next). No matter, I took the remote back. If I keep this car I will get a remote starter for it anyway and will not need the stock remote....Thanks.
What year is your vehicle? Depending on the year/model of car, there are two different ways to program. There is a split with the 2005 MY (according to your profile that is what you have) depending on the model. If you have a regular Impreza (not WRX or STI), the you do the 10 times within 15 seconds, open, close door, press button on remote, etc. If you have one of the other models, then it requires the other method, using the door lock switch.
RexyGirl is offline   Reply With Quote
Old 07-30-2014, 10:27 AM   #668
Forgiven
Scooby Newbie
 
Member#: 217001
Join Date: Jul 2009
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2005 Impreza
White

Default

It is in the post, 2006 is the year. Yes I did do all that the manual says. Thank you. It really doesn't matter at this point, I gave the transmitter back. I really appreciate your help.
Forgiven is offline   Reply With Quote
Old 08-01-2014, 05:22 PM   #669
pete68
Scooby Newbie
 
Member#: 187301
Join Date: Aug 2008
Chapter/Region: E. Canada
Location: gatineau quebec canada
Vehicle:
2005 sti
black

Default key fob dealer c'ant program it!!

key fob dealer c'ant program it!!
tried it myself without success !!
any help would be appreciated
2005 sti
thanks
pete
pete68 is offline   Reply With Quote
Old 08-06-2014, 08:51 AM   #670
rebeccahart05
Scooby Newbie
 
Member#: 398299
Join Date: Aug 2014
Default

I need help! I have a 2001 Subaru Outback that has a factory alarm system. I've had it for a couple years and it's always done this...every time I open the door, the alarm goes off, however I think the previous owner might have disabled the sound. I hear a clicking sound, and the little red light blinks. I cannot start the car until I hit the "unlock" button on the drivers side door or I use the key remote unlock button.

Is there a way to totally disarm this so I don't have to unlock every time I get in the car?
rebeccahart05 is offline   Reply With Quote
Old 08-06-2014, 10:20 AM   #671
Forgiven
Scooby Newbie
 
Member#: 217001
Join Date: Jul 2009
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2005 Impreza
White

Default

I had a similar problem in the 2006 car I just sold. I found the solution in the manual. I suggest you take a close look at your manual, it probably will be different than the one I had....as best I remember it I was able to cancel the alarm memory by opening and closing the driver's door and hitting the lock button a set number of times.....
Forgiven is offline   Reply With Quote
Old 08-08-2014, 03:10 PM   #672
pete68
Scooby Newbie
 
Member#: 187301
Join Date: Aug 2008
Chapter/Region: E. Canada
Location: gatineau quebec canada
Vehicle:
2005 sti
black

Default

Quote:
Originally Posted by pete68 View Post
key fob dealer c'ant program it!!
tried it myself without success !!
any help would be appreciated
2005 sti
thanks
pete

anyone !!!!!
pete68 is offline   Reply With Quote
Old 08-20-2014, 09:36 PM   #673
Phil Rex
Scooby Newbie
 
Member#: 395358
Join Date: Jul 2014
Chapter/Region: NESIC
Location: Massachusetts
Vehicle:
2004 wrx
wrb

Default

Did the 04 wrx's come with a remote with buttons? Cuz all I have is a key...for some reason when I disconnected the subaru security unit, and plugged it back in, and then plugged the negative and positive terminals to the junper(batterys dead), the security light blinks twice in 1 second, i cant start my car, and after about 5 seconds my car starts blaring its alarm. So I disconnect the negative to stop it. Idk why it does this, maybe its all cuz I disconnected the unit brain thingy and the system thought I was a thief or something...is there a way to fix this? Again I don't have a remote..for all I care id love to get rid of the whole stupid alarm, but will my car start if I do this? Or is there a special fuse under the steering wheel somewhere? Thanks
Phil Rex is online now   Reply With Quote
Old 08-20-2014, 09:37 PM   #674
Phil Rex
Scooby Newbie
 
Member#: 395358
Join Date: Jul 2014
Chapter/Region: NESIC
Location: Massachusetts
Vehicle:
2004 wrx
wrb

Default

And also the rear right door lock is jammed amd wont lock.....idk if that would set off the alarm
Phil Rex is online now   Reply With Quote
Old 08-20-2014, 09:43 PM   #675
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by pete68 View Post
key fob dealer c'ant program it!!
tried it myself without success !!
any help would be appreciated
2005 sti
thanks
pete
What happens when you try to program it? Are you sure it's a factory alarm? Was another alarm added? More info is needed to help you
RexyGirl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Factory Alarm + Keyless entry from 04 FXT Skidd Interior/Dressup/Audio & Security 0 01-22-2009 08:26 PM
Factory alarm/keyless entry install - Anyone want to help?! NickWRX Tri-State Area Forum 3 07-06-2008 09:22 PM
All you need to know about ass hair. WRick Off-Topic 22 01-23-2006 07:22 PM
Factory Alarm / Keyless entry Woody Vancouver Impreza Club Forum -- VIC 3 04-21-2002 11:51 PM
Factory alarm/keyless entry on MY01 Safir Car Audio, Video & Security 1 02-08-2001 01:01 PM


All times are GMT -4. The time now is 07:08 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.