Welcome to the North American Subaru Impreza Owners Club Thursday October 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-06-2003, 12:18 AM   #1
Stickee
NASIOC Supporter
 
Member#: 530
Join Date: Nov 1999
Chapter/Region: E. Canada
Location: I wonder how long you could ma
Vehicle:
2005 9-2x Aero
FastAr Red

Unhappy Removed 2nd air filter - downhill from there...

So I was having hesitation problems at low RPMs, anywhere from 1000 - 2000 RPMs. I decided to take out the 2nd air filter, as many people have done before, to see if it would help any. This was a big mistake. I put everything back together and start her up. The car starts, and then dies out. Tried this several times, and got the same thing.

I had to get going so decide to just put the filter back, and check on documented procedure for removing this filter. Well, the filter doesn't go in properly, and me and my dad have a hard time putting everything back together properly.

We finally do so, the engine starts, stays on, but now the idle is very rough. It wouldn't die as before, but the RPMs would go very very low, and bounce around.

First question, does anyone know how to adjust the idle? Would it help to just adjust the idle so that it is around 900 RPM?

I then had to drive to drop something off at my girlfriend's house. As I stop at the bank machine, I notice that the idle is now smooth, at around 700 RPM. It seems to have settled down. When I get to her house, I notice that the RPM remains steady at idle. Is it okay now?

CEL is now on, and I'll do a reset tomorrow night after work.

Can anyone diagonse this problem?

TIA



P.S. I'm driving to Pennsylvania on Friday, and I hope everything will be alright....
Stickee is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OT peaked around 3pm EST... and it's been all downhill from there. Asinine Off-Topic 20 03-27-2006 06:38 PM
How to remove air filter from cold air intake in 2002 WRX? brfatal Service & Maintenance 1 04-03-2004 12:57 AM
Removing box air-filter for race day? Bad/Good? Reiflex Technical Forum Archive 5 08-04-2000 12:49 AM
Part # for MY99 2nd air filter ShaneW Technical Forum Archive 6 05-08-2000 10:42 AM


All times are GMT -4. The time now is 03:17 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.