Welcome to the North American Subaru Impreza Owners Club Thursday October 20, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > General Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-25-2000, 03:59 PM   #1
Scooby Newbie
Member#: 382
Join Date: Oct 1999
Location: Omaha
Post Instrument lights not working

I was working on my car today installing the performance guage pack in the second din location, now my Instrument lights are not working. The lights worked fine and the guage lights work when I first installed the guage pack but after I screwed everything down the Instrument lights stopped working. The interesting part is that when I arm and disarm my alarm the Instrument lights still flash and the guage pack lights flash like they should.
Please help


P.S. the guages are only in the second din temporarily. I will mount them in the proper place as soon as I get the parts I need.
RSJeff is offline  

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash lights, hvac lights not working iwantmyWRX Interior & Exterior Modification 11 09-21-2010 11:37 PM
Tail lights/Parking lights not working toutanje Electrical & Lighting 8 10-13-2008 05:28 AM
dash lights and tail lights not working. eocarockwell Electrical & Lighting 1 04-24-2008 11:57 AM
Anyone else's rev light / warning light not work right? turbo tecnica Electrical & Lighting 7 06-05-2006 12:27 AM
tail lights and front position lights not working 1993 Legacy Electrical & Lighting 1 12-15-2004 05:01 AM

All times are GMT -4. The time now is 10:10 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.