Welcome to the North American Subaru Impreza Owners Club Monday April 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-19-2003, 09:10 AM   #1
NicEJ25
Scooby Specialist
 
Member#: 26155
Join Date: Oct 2002
Chapter/Region: E. Canada
Location: Levis,qc,ca
Vehicle:
2008 WRX 5dr
Dark Grey

Default 2.5 overheating, dunno what to do, please help !

I'm having problem with the 2.5 i put in my 93 impreza. the engine was OK before I did the swap, and now it's overheating. The head gaskets has been done, thinking it was the problem, and it was not. the thermostat is new, the radiator cap is new. what I can see is that, while the engine is running, air is getting in the system, forcing the coolant to get in the overflow tank, and when the tank is full, it's going out of the overflow tank. before I get the head gasket done, it was doing a weird thing when I would shut-off the engine while it was hot. after a few minute, the upper radiator hose was constricting, and the overflow tank was returning is the system after a few violent hose acting. after the head gasket has been done, It did not seem to do the upper hose thing, but I can see the lower hose is constricting while I rev up the engine, and I suppose no or little coolant can get thru the hose then. what the hell is going on ???? I'm supposed to do a pressure test in the cylinder soon. no crack where visible in the combustion chamber nor the cylinder liner when the engine was dissasembled
NicEJ25 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
new and dont know what to do, please help! gygibigi Newbies & FAQs 3 12-26-2008 05:48 PM
No rear O2 sensor EJ257 What to do?? Please Help crazyGC8 Factory 2.5L Turbo Powertrain 3 05-15-2006 10:23 PM
OT: My PS2's RIP and I dunno what to do!!! kiddo Vancouver Impreza Club Forum -- VIC 31 01-31-2005 04:53 AM
I got the best xmas present ever and I dunno what to do b_tapper Off-Topic 218 12-27-2004 04:35 PM


All times are GMT -4. The time now is 08:42 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.