Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 09-02-2003, 11:27 AM   #1
MattJP
Scooby Specialist
 
Member#: 1280
Join Date: Apr 2000
Location: Pittsburgh, PA.
Default mositure makes my car run bad...help!!

My 00 RS runs like crap if it sits in the rain or in humid conditions for a while. It sputters, misfires like its not firing on all cylinders until it gets warmed up. Anyone have any ideas on what I should do first??

Thanks in advance for any tips or suggestions...

Matt -
MattJP is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
TGV deletes, and then a boat load of fail. Please help make my car run nicely again. 573 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 11 04-03-2010 12:15 PM
Uppipe making my car run like doodoo? RNBauer Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 04-29-2008 10:34 AM
excedy clutch i think making my car run richer VAUGHNB19 Transmission (AT/MT) & Driveline 3 10-04-2006 09:54 PM
How an EM can make my car run smoother?? BBBsti LTD Engine Management & Tuning 2 07-05-2005 11:44 AM
Would a bad 02 sensor (P0037) make my car run bad? skimmilk68 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 11-04-2004 01:33 PM


All times are GMT -4. The time now is 02:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.