Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-04-2003, 11:53 PM   #1
rjrutzky
Scooby Specialist
 
Member#: 30367
Join Date: Nov 2002
Chapter/Region: South East
Location: nashville, tn
Vehicle:
2005 Legacy GT
NASA SE PTB Champ

Default APS TMIC install

Man, I thought this would be easy. Big mistake. First took forever to get this thing crammed in there and get the bov, turbo and TB hose to line up. This thing being heavy as hell didn't help the cause either. Then I tried to salvage my whiteline strut bar and thought I was successful, but when I started the car it started shaking because the strut bar was touching the IC which was on the motor. Then I was so happy I was done I didn't realize the IC was laying on the turbo top coolant hose. Test drive went saw, saw, psshhhh. Luckily I didn't leave the neighborhood and coasted it on home. Tomorrow I have to figure out how I can route the new coolant hose. Got any ideas. Oh and I managed to fit the APS splitter to my CF hood with a regular size scoop no problem. Just had to vent--I'm pouring a drink and going to bed

PS
I bought the IC and splitter from bikerboy a highly recommended seller. Although my back and knuckles are cursing him now.
rjrutzky is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Process West TMIC Installed & APS 65mm CAI sszyma Car Part Reviews 41 12-23-2010 07:40 PM
WTB: APS 70mm Intake, APS TMIC BOV, APS TMIC MKXIII Private 'Wanted' Classifieds 0 07-27-2007 12:41 AM
cel after installing APS TMIC with cobb 2.5 AndyWRXWG Engine Management & Tuning 12 11-30-2005 05:56 PM
Need help with install on used aps tmic hybrid gti 2 Factory 2.0L Turbo Powertrain 5 06-14-2005 09:36 PM
The APS tmic is installed. Brewmaster New England Impreza Club Forum -- NESIC 3 06-05-2003 10:47 PM


All times are GMT -4. The time now is 01:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.