Welcome to the North American Subaru Impreza Owners Club Friday November 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Outback Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-12-2003, 08:36 PM   #1
Stephon
Scooby Newbie
 
Member#: 50449
Join Date: Dec 2003
Vehicle:
1997 Legacy Outback

Question Heater and Temperature Problem

I'm driving a '97 Legacy Outback automatic with 100K+ miles on it.

The weather is cold here, so after the car had warmed up I turned the heater on, but got cold air coming from my vents.

About 2 minutes after dicovering that, my temperature gauge shot all the way to the top.

I turned for home, turning the car off as needed to let the engine cool.

Seemed normal otherwise. No odors or smoke coming out of the car.

Any thought on what's going on?
Stephon is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turbo 2.0 in porsche 914 Temperature problems budman5201 Newbies & FAQs 5 07-05-2009 02:20 PM
Thermostat/Temperature Problem on my 98' RS greenhand Normally Aspirated Powertrain 10 01-05-2007 02:01 PM
STI pinks and nitrous express wet system with heater and purge valve. scooby Private 'For Sale' Classifieds 14 01-17-2005 02:26 PM
Temperature Problem hernan Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 04-20-2004 07:19 PM


All times are GMT -4. The time now is 10:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.