Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-04-2004, 06:07 AM   #1
03ShrtBus
Scooby Newbie
 
Member#: 43757
Join Date: Sep 2003
Location: Downingtown, PA
Vehicle:
2003 WRX Wagon
Sonic Yellow

Question Wagon Suspension- read and post your setups

Need help on my Suspension. Long story short i Got Progress springs for free and I just installed my Rota Attacks and Potenza tires. They are 225/45/17. I have a pretty severe rub in the back and barely any rub up front. I am a big fan of the tires and wheel and don't want to lose them. I have available to me a set of H&R Springs. The H&R's as many if not all of you kno don't sit quite as low. Any help in this manor is greatly appreciated and if it could be sooner then later............thanks again

PS.........WAGONS POST YOUR SETUPS AND IF YOU HAVE RUBBAGE
03ShrtBus is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The HID FAQ Thread - Read before posting your questions dithergizzard Electrical & Lighting 600 03-10-2014 09:27 AM
What does your rim/tire combo weigh? Post your setup + weight Trevor723 Tire & Wheel 42 06-04-2010 10:40 PM
Post your setup... az ej20 fan South West Impreza Club Forum -- SWIC 20 02-10-2004 11:59 PM
Are these gauge readings correct? post yours too please! T33 Factory 2.0L Turbo Powertrain 7 04-28-2003 01:35 PM


All times are GMT -4. The time now is 06:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.