Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-01-2004, 12:44 AM   #1
SmoknWRX
Scooby Newbie
 
Member#: 44983
Join Date: Oct 2003
Location: Va.Beach/school at Radford
Vehicle:
2003 impreza wrx
aspen

Unhappy Knock At Low Boost...help

OKAY GUYS, HERE ARE MODS.....INTAKE,UP PIPE, TURBOBACK EXHAUST WITH NO CATS, AND UTEC STG2 MAP.

HERES THE PROBLEMS, 2 WERE RESOLVED TONIGHT

1. INCONSISTENT IDLE
2. between 4-5k rpms and 20-40% throttle the car begins to sputter and some times results in the car to jump back and forth. after logging it i noticed the injector duty was jumping from 20-40% to 70% and back down in the matter of split seconds.

THESE PROBLEMS FIXED BY THE REMOVAL OF MY MAF SENSOR

3. heres the big problem.......its really cold outside and yet i cant run more than 14 psi without knock. turbo xs said that with my mods i should be running 16.5-17 psi. my friend is running the exact same setup and is peaking at 18.5psi. what the heck is going on??
right now ive turned the boost down to 12 psi and still see knock after full aceleration thru 1st and 2nd gear and let off the throttle right after my shift into 3rd. so its still knocking right as i back off the throttle in the begining of 3rd.

i have not altered the fuel/timing map since i uploaded it from TXS.

and why cant i get full boost in all gears?? would adding a MBC that totally bypasses the use of the stock solenoid help me out?

if your still reading this thank you for staying with me through all this typing, hahaha. if u can help me out any itd be awesome, thanks!!!!
SmoknWRX is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
knock at low load? austria impreza Engine Management & Tuning 9 10-10-2009 02:25 PM
Engine knock at low RPM's rek888v2 Factory 2.5L Turbo Powertrain 12 01-02-2006 10:30 AM
Steering column knock at low speeds Jitenshakun Canada Region Forum 10 01-14-2005 10:03 AM
Knock at low rpm and throttle PharmCo Factory 2.0L Turbo Powertrain 4 02-02-2004 10:28 PM
Knock At Low Boost....help SmoknWRX Factory 2.0L Turbo Powertrain 9 02-01-2004 07:23 PM


All times are GMT -4. The time now is 06:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.