Welcome to the North American Subaru Impreza Owners Club Sunday November 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-19-2000, 09:09 PM   #1
Scooby Newbie
Member#: 2381
Join Date: Sep 2000
Location: Monroeville,PA,USA
Have a Nice Day? Please please help me!!!!!!

I have an OBS and just installed a MY00 RS front bumper with all the goodies including subaru fog lights, new bumper beam, clear turn signals, it look great. I had driven the car later that day and no probs. Tonight i was coming homw on the highway and all of a sudden the car was acceleraating by itself!!! The first thing i though was that the floor mat was stuck but i check it and it wasnt. I was really pressing on the brake and i was barly slowing down. I shifted into neutral and the RPM went WAY up past 7000!! I love my car and i decided not to blow up my enging and pulled over. I poped the hood and there was no kind of hangup on the gas cable thingy and i decided to try again. Same frekin thing, i barly made to the dealership and am leaving it overnight, any suggentions?, I think that they are going to tell me that i did some thing while installing the bumper and of fog lights? (i didnt use the factory wiring harness, i bought one a an autoparts and used it so that i could run higher watt bulbs) Thanks, Brian Valen
brivalen is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please to help me recover my HDD! Lachlan Off-Topic 7 06-24-2005 08:55 AM
Please someone help me sell this quick!!! Flyn'Rex Texas Impreza Club Forum -- TXIC 5 10-07-2004 11:35 PM
Pretty pretty please someone help me find the WoW Stress Test Client for download... Asinine Off-Topic 2 09-01-2004 02:01 PM
Please God help me with insulation advice! BrysImpreza Interior & Exterior Modification 9 01-02-2002 02:52 AM
Please someone help me! nikkicalves Canada Region Forum 0 08-11-2001 12:51 PM

All times are GMT -4. The time now is 10:25 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.