Welcome to the North American Subaru Impreza Owners Club Monday November 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-22-2004, 10:06 PM   #1
Scooby Specialist
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
6-4 jockin da bish-
es and slappin the hoes.

Default Is my ECU dead?!?!

i just did a ej2.2t ecu and harness swap into my 95 impreza 1.8, and i don't have any spark and the output from the ecu to energize the relay doesn't output any power and i hooked up an alarm L.E.D. for a CEL, one side ign and one side i believe is the MIL wire is, and it never flashes. i don't have my dash in, but that shouldn't make a difference right? the ECU is Automatic and the car is Manual, i put ignition power to the wire for a park and nuetral switch then grounded 2 other wires (b9,B10 i believe) for the nuetral safety switch

the only other thing is that i didn't have one of the crank and cam sensors for the legacy so i soildered the impreza 1.8 sensors in should be the same as the legacy, aren't they, minus the shields?
bobturismo is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my alternator dead or is it something else? Jus Blaze Electrical & Lighting 4 09-22-2008 11:09 AM
Is my router dead-dead, or just....mostly...dead sonicblue Off-Topic 10 07-21-2008 01:10 PM
Tuning my WGDC, is my turbo dead? arch4life Open Source Reflashes 14 03-26-2008 04:43 PM
Is my starter dead or is it a bad connection? DoinkMobb Service & Maintenance 13 12-30-2003 08:42 PM
is my amp dead? sybir Car Audio, Video & Security 3 03-28-2002 04:36 AM

All times are GMT -4. The time now is 08:37 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.