Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-21-2004, 10:31 PM   #1
kAn9ArOo
Scooby Newbie
 
Member#: 2294
Join Date: Sep 2000
Exclamation help! piaa xt pro 80

i am having the worst time wit these fog lights.
i got them, installed them, and they worked for like a week.
today i opened the housing to check the bulbs and the bulbs are fine. now, i can't put the housing back together cuz these stupid lil brackets that the screws go into fell off and theyre on the inside of the housing! how am i supposed to screw them in place when they can only be secured to the screw from the outside?! damn! i wired my fog lights to the stock switch. when i press the switch i hear a click from the relay, but no power no lights! *** is going on. this is pissing me off, im about to buy stock foglights, this sucks. someone help meeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee eeeeeeeeeee!!!!!!!!!!!!
kAn9ArOo is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PIAA 80-XT Pros brucelee Car Part Reviews 1 05-19-2007 03:13 AM
piaa xt 80 pro lens???! kAn9ArOo Electrical & Lighting 2 08-21-2006 07:44 PM
anyone with piaa xt 80 pros!! kAn9ArOo Electrical & Lighting 1 03-06-2004 08:00 PM
help! my piaa xt pro 80s kAn9ArOo Electrical & Lighting 10 01-27-2004 11:12 PM
anyone have piaa xt 80 pros? kAn9ArOo Electrical & Lighting 4 01-22-2004 10:26 AM


All times are GMT -4. The time now is 06:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.