Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Forester Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-10-2004, 01:01 PM   #1
ForesterXT04
Scooby Newbie
 
Member#: 42249
Join Date: Aug 2003
Default Peaty-- SpeedBleeder Question

I installed 4 speedbleeders on my 2002 Maxima today. The speedbleeder is a little longer than the OEM that was on my Maxima.

So, I remove the old bleeder, install the new speedbleeder, then back it off 1/4 of a turn. I bled the brakes and tightened it back on. I don't have a torque wrench in inch pds, so I tightened it until I met some resistance then gave it a little more (1/4 turn or less). While the wheel was off, I cleaned all four wheel wells, springs and calipers with Simple Green and a brush.

I took the car on a test drive and all went well. Came back and felt around the bleeder and 3 of the 4 have some brake fluid there (less than a drop but enough to show on my finger). It's not dripping, but there is some fluid there.

My question is, how tight should I get these or is it normal to have a little leak out at first? I'm worried about breaking them off if I tighten too much.
ForesterXT04 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stock turbo boost issues: few questions... dman918 Factory 2.5L Turbo Powertrain 9 07-08-2010 11:50 AM
speedbleeder question darkmist2k1 Tri-State Area Forum 0 01-17-2005 04:30 PM
Attn: Peaty, and others, question! SubaruRules Forester Forum 1 11-10-2003 07:10 AM
KC Guys and where's Peaty Patrick L Mid West Subaru Owners Club Forum -- MWSOC 16 08-24-2001 07:18 PM
('93-'01) Happy Birthday Peaty! tom@kartboy Impreza Forum 8 07-21-2001 07:58 PM


All times are GMT -4. The time now is 09:27 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.