Welcome to the North American Subaru Impreza Owners Club Sunday August 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-05-2004, 04:19 PM   #1
Santo Domingo 2.5 RS
Scooby Specialist
 
Member#: 5354
Join Date: Apr 2001
Location: Santo Domingo. R.D
Vehicle:
2000
Silverthorn Metallic

Default It Blew, I knew this was going to happen one day!

Well! yesterday I was out with some of my friends and we were doing some street racing on this open road (dont come flaming me for this now). Well Im next to my friends turbo Type R and we gun it, We just side to side, and some kid gets in the way while Im in 2nd gear, so I hitted the rev limiter for a couple of seconds because I distracted myself with the other car. The when I get in to 3rd, a couple o seconds later I feel the car loosing power and after this a big ass cloud of smoke in my rear view, I let off the gas and and the car starts hesitating, i knew it right there, so Since I live like 5 minutes from the place I come back home, the car idle goes up to 1200-1400 and the motor is shaking, like one of the pistons is death and lots of smoke is coming out of my tailpipe, well, since it was realy late I turn off the car and get in to the house, hoping to check everything out in the morning.

This morning i got up, and went to check, first i check my catchcan, I has some oil in it, maybe 2 or 3 full spoons of oil, there had never been any oil in my catchcan beafore. I checked everything and there was lots of oil around by the exhaust manifold on the passenger side. I then turned on the car, it started hesitating and the motor was shaking, lots of smoke coming out of my tailpipe and high idling, but no audible knock or any kind of extrange sound was coming from the engine. I Disconeected my PCV and lots of white smoke was coming out of it. My boost gauge is connected on cylinder No3 Intake manifold runner and i could see oil in the clear plastic tube coming out of it. After this, I tried checking for the bad piston and umplugged the sparkplug cable for piston No.3, and nothing happenned the car did not stumble down or anything like it, so I thought this was the bad piston. I did the same thing with all of the other cables and everytime I disconnected one, the engine was allmost dying and starter shaking a lot worse. After, I turned it off and got all of my sparkplugs out, the one in piston No.3 was full of oil, piston No.1 looked like burning rich and the other two looked just fine. Im thinking that this is just a case of fried piston ring, but Im not sure since none of this stuff has ever happenned to me beafore. any of you guys have any idea of what might be wrong. .

what did I get myself in to??

My setup:
T3/4 .60Ar
6:1 RRFPR
J & S Safeguard
WRX fuel pump
6.6 PSI creeping to 7 sometimes
Santo Domingo 2.5 RS is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I knew it would happen one day........ smileyou Off-Topic 50 02-12-2009 05:44 PM
I knew it was going to be a bad day when... Matt A Off-Topic 18 11-14-2006 09:25 AM
Is the HB meet this friday going to happen? I am mattjk Southern California Impreza Club Forum -- SCIC 27 07-14-2003 10:55 AM
I knew it was going to happen . . . lethargicman Southern California Impreza Club Forum -- SCIC 35 01-01-2002 03:36 PM
well it was going to happen sooner or later dynoguy Mid West Subaru Owners Club Forum -- MWSOC 4 08-13-2001 09:21 PM


All times are GMT -4. The time now is 06:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.