Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-30-2001, 02:50 PM   #1
yebokmj
Scooby Specialist
 
Member#: 2213
Join Date: Aug 2000
Chapter/Region: South East
Location: Raymond, NH USA
Vehicle:
1995 Impreza w/EJ257
Brilliant Red

Question Re Post: Need help with RS-T ECU Code Malfuctions, and if TEC II will Solve it.

I posted this before but it wasn't when we had a aftermarket turbo forum and it didn't get much attention. Here it is again and here is the origional . Also I did try what wayne suggested along with running a new ECU.
I am having alot of codes on my car. They all started when JC Sports sent me a defective Torque Chip II which messed up all my sensors and my ECU. In Fact with in an hour of install blew my ECU Fuse. I have tried replacing Both O2 sensors, which is one of the codes being thrown, with no change. The O2 Sensor are also only reading at .30V both with the new and the old ones. Here are the codes being thrown please help.

P0403 EGR Circuit Low

P1102 Pressures Sources Switching Solenoid Valve Circut Low

P0505 Idle control System Malfunction

P0443 Canister Purge Control Solenoid Valve Circuit Low

P0141 Rear O2 Sensor Malfunction

P0135 Front O2 Sensor Malfunction

Any help would be apprecited. I am thinking for some of the code that maybe I need check valves on certain vacuum lines? Also I was thinking of going TEC II but since it's running along with the stock ECU, one of the things being Idle control. I don't know if it would solve my problems.
Thanks,
Joshua
Subaru Salesman
yebokmj is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need help with ecutek easy ecu scorpio75 Commercial ECU Reflashes 1 02-19-2007 08:51 AM
I need help with friend STi ecu ?? qtr_wrx Engine Management & Tuning 2 01-26-2007 07:20 PM
Need help with RS hood ASAP RSimport Mid Atlantic Impreza Club -- MAIC 10 07-11-2003 01:45 PM
I need help with RS-t, please (long) scootr Normally Aspirated with bolt-on Forced Induction Powertrain 8 12-11-2002 12:26 PM
Need help with RS-T ECU Code Malfuctions, and if TEC II will Solve it. yebokmj Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 05-31-2001 08:34 PM


All times are GMT -4. The time now is 07:51 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.