Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Other Engine Management

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-17-2004, 12:43 PM   #1
STi_Drift
Scooby Newbie
 
Member#: 25759
Join Date: Oct 2002
Vehicle:
99 impreza
rally blue

Default Hydra finally working

So after a lot of toiling and work, testing and help from Andrew. I got the Hydra tuned and running. The system works well and Andrew is always there to help. I have to say the system is still so new that we are all basically beta testers at this stage, but once you get it running the system is pretty damn good.

My setup is an Ej22t RS Heads and a VF29 on 18 psi driven daily. The car is not bad, but not as fast as I wanted. Time to get a bigger turbo

Anyways thanks to Andrew and props to him. I know a lot of guys have been giving him a hard time, so i thought I would share my experiences too.
STi_Drift is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
my car finally works again! mcleod Mid West Subaru Owners Club Forum -- MWSOC 2 06-11-2002 10:32 AM
MRT Intercooler Spray - FINALLY WORKS! hotsam Factory 2.0L Turbo Powertrain 3 10-21-2001 12:21 AM


All times are GMT -4. The time now is 01:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.