Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-23-2005, 02:43 PM   #1
pk.v1.0
Scooby Newbie
 
Member#: 81092
Join Date: Feb 2005
Default ticking emergency lights after fuel filter replacement

Could anybody help me with this.

I replaced the fuel filter today, went okay.

However, after I started the engine and checked for leaks, something strange started to happen - the emergency lights and also the dash panel lights now turn on and off with a ticking sound. They do so at a slower frequency than when you switch on the emergency button. Starting or shutting down the engine does not help. I also found no mention of such behavior in the manual.

Please, help me!
pk.v1.0 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car won't run after fuel filter and plugs replaced 96soobaru Newbies & FAQs 4 04-09-2009 11:21 AM
Fuel Filter replacement - where is fuel pump relay? SeenDubAYouAreEx Newbies & FAQs 4 07-11-2007 09:29 PM
wrx fuel filter replacement phillywrx Service & Maintenance 9 10-10-2002 12:12 PM
Fuel Filter Replacement? Ryan24 Service & Maintenance 8 08-07-2002 10:59 AM


All times are GMT -4. The time now is 02:25 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.