Welcome to the North American Subaru Impreza Owners Club Friday January 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-17-2005, 12:55 PM   #1
staticfritz
Scooby Specialist
 
Member#: 66934
Join Date: Jul 2004
Chapter/Region: NWIC
Location: Seattle WA
Vehicle:
2004 JBP FXT
2002 cammed OBS - RIP

Default nasty idle....searching?

i rebuilt an ej25 last weekend to go in my car.

spicy cams, new valvesprings, light flywheel, cai, el-headers, cometic gaskets

i'm getting a real nasty idle,it's spends a lot of time searching (from ~500-1000rpm) and i get crazy vibration. as soon as i touch the throttle, the vibration goes away. crusing at 3-4krpm, the shiftknob is vobrating a fair bit. other than that, car drives fantastic, but what to do about my idle?

is it possible the timing belt is off by one tooth on a cam sprocket? (i'm 95% sure it's not off, but...?)

i'm running really rich right now too. matt suggested hotter plugs (93 octane)...could this be the source of my problems?

any suggestions or help form those of you more experienced in the n/a stuff would be great.
staticfritz is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
So I have searched for days.(seriously) Hi Idle after 2.5 swap turbored02 Subaru Conversions 4 06-16-2009 08:05 AM
Rough idle when warm, 01 RS, yes I searched ;) rogue Normally Aspirated Powertrain 6 05-13-2009 06:39 PM
Searched! P0442 code with Rought idle.... erickrm Newbies & FAQs 6 06-25-2008 01:18 PM
TD06 18g install and idle search blue m&m Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 7 09-28-2006 11:21 PM
some help please idle issues(I've searched, trust me) Lavery Normally Aspirated Powertrain 11 11-14-2005 10:26 AM


All times are GMT -4. The time now is 05:38 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.