Welcome to the North American Subaru Impreza Owners Club Friday January 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-04-2005, 10:31 AM   #1
attitude
Scooby Specialist
 
Member#: 52043
Join Date: Jan 2004
Chapter/Region: MAIC
Location: Huntington WV
Vehicle:
04 sti

Default fuel pump not priming/ecu not on?

i was driving my car last night and it shut off. when i try to start it, the fuel pump wont prime, the utec doesn't have the lights on it either. my avc-r is tapped to the ecu wires, and it is getting power. i have a bad feeling that the utec or ecu are fried. anyone else have similar problems?

mods:
utec
tuner pro
all fuel mods
t-67
tgv delete
front mount
big maf
etc.
attitude is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pump continously priming on swap speedymaker Subaru Conversions 1 03-22-2010 09:20 PM
fuel pump wont prime legacy1907 Subaru Conversions 3 12-21-2007 12:22 PM
Fuel Pump wont prime!! 02ej257 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 12-08-2006 04:45 PM
FS: Walbro Fuel pump (NEW), CObb ecu, TXS axleback WRX Jim Private 'For Sale' Classifieds 7 10-18-2003 07:32 PM
PE fuel pump dies - POS - need info on supra pump alfriedesq Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 26 02-20-2002 09:25 AM


All times are GMT -4. The time now is 12:02 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.