Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-17-2001, 05:21 PM   #1
TheWRX
Scooby Specialist
 
Member#: 10279
Join Date: Sep 2001
Location: St. Louis, MO
Vehicle:
2005 Lotus Elise
Yellow, #94 SS

Default WRX deceleration noise update

I just had a phone conversation about the WRX deceleration noise (grinding when lifting off the throttle, it has been discussed extensively on the boards) with a service advisor at my dealer. The latest word is that Subaru is aware that this is a common problem, and is working on finding a solution. Until they get instructions from SOA on how to fix it, they told me to basically just deal with it. They say that it's not a safety issue, and that there was no need to worry that the defect would result in other parts getting damaged.

He didn't seem comfortable talking about possible causes, but he indicated that they managed to fix the noise on another car earlier, after many attempts. I mentioned the post of the guy (variac) saying:

Quote:
What they ended up doing was replacing the clutch disc, pressure plate, flywheel and bolts. I just picked the car up today, and so far so good... no longer has the noise. The clutch parts they put in were somewhat redesigned, ..
He wasn't very clear in his response, but my understanding was that they also replaced the clutch disc, and possibly other parts. When I tried to pin him down on this being the likely cause, he said that they couldn't be sure that the noise wouldn't come back.

So my current guess is that we can hope for redesigned clutch parts that will solve the problem. I hope it won't take too long... The service advisor told me that he would be mentioning the issue to the local service rep each time he sees him.
TheWRX is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Deceleration Noise Issues: Clutch Only. WRX Pilot Warranty Issues & SOA Problems 147 12-20-2002 08:41 PM
Deceleration Noise Issues: Clutch Only Dat Southern California Impreza Club Forum -- SCIC 13 04-19-2002 04:44 AM
Decelerating noise Blindeye_03 Brakes, Steering & Suspension 8 04-11-2002 05:28 PM
Deceleration noise similar to WRX liberty Warranty Issues & SOA Problems 1 02-13-2002 09:44 PM
Deceleration Noise Poll (popular demand) FargoRS Warranty Issues & SOA Problems 0 12-06-2001 11:43 AM


All times are GMT -4. The time now is 01:39 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.