Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-24-2002, 07:09 PM   #1
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default Anyone take off their radiator cap?

Well actually on the WRX it's on a separate housing and not on the radiator, but anyway-
I looked under there the other day and the paint inside the neck under the cap was flaking off and the surface was orange with corrosion, yuck. Just wondering if anyone else has noticed this on theirs?
* Registered users of the site do not see these ads.
Mulder is offline   Reply With Quote
Old 07-24-2002, 10:31 PM   #2
jhuang76
Scooby Newbie
 
Member#: 1284
Join Date: Apr 2000
Vehicle:
2005 Legacy GT
Royal Blue Pearl

Default

Along the same lines, on my 2000 RS, at about 29k miles, I drained the stock coolant and there was these white "flakes" in the coolant. And the back of the cap had whitish deposits. The only topping off I've ever done was with Subaru coolant w/ distilled water (at least I assume my mechanic friend was using that). Still, the top-off did not amount to more than a few cups over 29k miles. A good antifreeze should even take tap water and still prevent excessive deposits. Makes me wonder about the quality of Subaru coolant (but then again, what would you expect since it's not unusual for OEM's to buy lowest bid items).
jhuang76 is offline   Reply With Quote
Old 07-26-2002, 06:10 PM   #3
Stanley
Scooby Guru
 
Member#: 7374
Join Date: Jun 2001
Location: North Bay, SFCA
Vehicle:
2007 Grandpamobile
BlingBlingBlue

Post

I had the exact same experience when I flushed my cooling system a few months ago. Paint flaking off and floating in coolant.

BTW, that housing with the radiator cap on it is the highest point in the engine, located directly above the turbo. Theory is that if the turbo is hot enough to vaporize the coolant, it goes into the reservoir and draws cooler liquid coolant into the turbo even when the car is turned off.
Stanley is offline   Reply With Quote
Old 07-27-2002, 09:18 AM   #4
chuglobal
Scooby Specialist
 
Member#: 10041
Join Date: Sep 2001
Location: Marietta, Ga.
Vehicle:
2015 WRX Limited CVT
ISM

Default Humm ...

Ironically I noticed that same thing last week when I had nothing to do so I removed the cap and noticed the same thing? Weird? I have no idea so I manually got rid of the pieces and put the cap back on.
chuglobal is offline   Reply With Quote
Old 07-27-2002, 08:17 PM   #5
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Exactly what I did, and I'm not overly concerned about it, I was just wondering if anyone else had noticed the same thing, now I know.
Mulder is offline   Reply With Quote
Old 07-31-2002, 04:05 PM   #6
silverSurfer
Scooby Specialist
 
Member#: 1361
Join Date: Apr 2000
Chapter/Region: Tri-State
Location: Used to be Long Island/NYC...
Vehicle:
1999 Legacy GT Ltd.
2006 Rav4 Sport Silvarrr

Default

jesh. it's normal
silverSurfer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What's up with bikers on choppers who feel the need to take off their blinkers? nos Off-Topic 33 08-22-2006 09:53 AM
Anyone take apart their foglights??? Need help with this mod.. MomoWRX Interior & Exterior Modification 8 10-24-2003 08:26 PM
Anyone have a spare radiator cap for the RS? TaiChih Mid Atlantic Impreza Club -- MAIC 4 10-20-2002 10:00 PM
Anyone have an OEM radiator cap? Ken Vancouver Impreza Club Forum -- VIC 4 06-10-2002 03:38 PM
Anyone else take off their front plate? Code-7 Alaskan Impreza Club Forum -- AKIC 13 03-22-2002 01:22 AM


All times are GMT -4. The time now is 03:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.