Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-30-2002, 12:21 AM   #1
annointed
NASIOC Supporter
 
Member#: 5960
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Atlantic City, NJ
Vehicle:
FXT 11.6@118 93 oct
NSX 450 whp SC'd (93 oct)

Unhappy Power steering pump whine, fluid boiling...

I've been having to refill my PS fluid on a weekly basis due to a leak, so today I flushed out my PS fluid, took off the resevoir, rebolted it, and refilled the resevoir, and now the pump starts to quietly whir with the engine rpm level after ~5 miles of driving, and progressively gets louder and more excruciating...it also groans when I turn. I don't notice this whir/groan when the engine is cold.

I checked the PS fluid each time after stopping, and its boiling/bubbling, so either its too hot, or maybe the bubbles are just trapped air getting out. I did overfill the resevoir, so I removed some of the fluid, but the problem was still there after another 10 mile drive.

Based on a search, I think I'm going to lock the wheel from right to left a few times after starting the car for the next few days, and see if the air works its way out, and the noise dies down. I'm also going to be watching to see if the fluid continues to leak.

Any insight is appreciated.

Thanks.
* Registered users of the site do not see these ads.
annointed is offline   Reply With Quote
Old 07-30-2002, 09:55 AM   #2
BamBooI
Scooby Specialist
 
Member#: 10945
Join Date: Oct 2001
Chapter/Region: South East
Location: SC
Vehicle:
2006 Evolution IX

Default

I remember some people having to replace their power steering pumps b/c they went bad. Thats is all I kknow.
BamBooI is offline   Reply With Quote
Old 07-30-2002, 12:08 PM   #3
PLAYER
Scooby Newbie
 
Member#: 19340
Join Date: May 2002
Location: Melbourne Australia
Vehicle:
94 Impreza WRX
Red

Default

Dont bother posting this stuff just email me direct!
Been there done that, rear bearing is stuffed because of belt being too tight at some stage, take it apart, remove the rear bearing and press in a caged needle roller bearing after opening the old hole to .512" (9mm) approx, replace the front bearing at the same time, its worth about $20 all up from a bearing supplies shop and any machine shop can open the hole out for you successfully.
Try synthetic gear oil in it I found that helps if you can't do the above mod.
They all suffer from this in time, you can't get the rear bearing from Subaru, only a complete rear housing so forget that idea.
Taking it apart and putting it back together is a piece of cake for even dumb people.
PLAYER
PLAYER is offline   Reply With Quote
Old 07-30-2002, 12:31 PM   #4
RiftsWRX
Scooby Guru
 
Member#: 6124
Join Date: Apr 2001
Chapter/Region: MWSOC
Location: Glendale Hts, IL, USA
Vehicle:
2000 NFR AP1 S2000
'07 Honda FIT sport (5MT)

Default

Quote:
Originally posted by PLAYER
Dont bother posting this stuff just email me direct!

Taking it apart and putting it back together is a piece of cake for even dumb people.
PLAYER
Not to be an ass.... but maybe us "dumb" people can learn from it being posted here... unless you all of the sudden want 23k emails from the n00bs filling your inbox?

"DING... you have mail!"

Jorge (RiftsWRX)
www.ProjectWRX.com
RiftsWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power steering pump bearing whine - time to live? silfreed Brakes, Steering & Suspension 19 12-07-2010 01:08 PM
WTB/WTT : Power Steering Pump hojman SCIC Private Classifieds 16 06-10-2010 08:19 PM
Power steering noise but maybe not the power steering pump.....? deathskrye Brakes, Steering & Suspension 5 08-29-2008 10:56 PM
Power steering pump, whines, hissing sound.. braided lines and aps kit related DJIMPREZA Brakes, Steering & Suspension 2 12-15-2007 10:02 AM
Power steering pump, STi V4. Any other pumps fit? STi_v4_Wagon Brakes, Steering & Suspension 0 12-30-2006 11:19 PM


All times are GMT -4. The time now is 10:56 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.