Welcome to the North American Subaru Impreza Owners Club Monday July 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-05-2014, 11:15 AM   #51
Omni003k
Scooby Newbie
 
Member#: 348963
Join Date: Mar 2013
Chapter/Region: MWSOC
Location: Carbondale, IL
Vehicle:
2008 WRX
Lightning Red

Default

You can buy a new pinion valve, the complete assembly, for $250, if you are somewhat mechanically inclined and have some tools, jack, and jack stands you can do this in your driveway in a few hours, if that. The valve assembly is what leaks, the rest of the rack is fine. The hardest part of the fix is not stripping the PS line fittings. It is alot easier to buy a whole new rack, but it will be pricey for a new one, and I don't trust re manufactured ones.
* Registered users of the site do not see these ads.
Omni003k is offline   Reply With Quote
Old 03-10-2014, 01:57 PM   #52
LoveMyNewSoob
Scooby Newbie
 
Member#: 323213
Join Date: Jun 2012
Location: Atlanta
Vehicle:
2009 WRX Sti hatch
Spark Silver

Default

I am just now dealing with this one too! 09 STi with 65K (I did two track days last year). I went to the dealership last weekend and they quoted me $1200 for a new rack!!!
I did just find this thread though and the picture is pretty much exactly how mine looks.

http://www.iwsti.com/forums/warranty...aks-badly.html

There is a local Subaru specialist near, so I am hoping they can fix the problem cheaper.
LoveMyNewSoob is offline   Reply With Quote
Old 03-11-2014, 07:40 PM   #53
l3ighead
Scooby Newbie
 
Member#: 162552
Join Date: Oct 2007
Default

Ordered one from RockAuto.com I believe it was a A1 Cardone refurbished rack. Its only been a day so far no issues. I read negative reviews about the company along with good ones. So far its holding up well. Cost was $370 will be getting $115 for core return. =
l3ighead is offline   Reply With Quote
Old 04-03-2014, 11:07 AM   #54
Lindyn11
Scooby Newbie
 
Member#: 326221
Join Date: Jul 2012
Chapter/Region: South East
Location: Fort Smith, Arkansas
Vehicle:
2011 WRX
WRBP

Default

2011 WRX (49,700 mi)

Noticed the leak while performing 50k service. Slow leak at the input valve on the rack. Keeping fluid topped until I take it in.
Lindyn11 is offline   Reply With Quote
Old 04-30-2014, 12:49 PM   #55
silverbullet830
Scooby Newbie
 
Member#: 155658
Join Date: Aug 2007
Chapter/Region: TXIC
Location: Baytown, TX
Vehicle:
2010 WRX Sedan
WRB

Default

My 2010 wrx started leaking at about 45k miles about a year and a half ago when I was in Alaska. At the worst I had to top it off about every 3 or 4 days. As of a few months ago (now at 61k) its actually slowed down to only filling it every 2 or 3 weeks lol. I think I will go with a reman rack off ebay most likely. A lot of people say they don't trust the rebuilt ones compared to factory, but I mean seriously look at how many failures the stock units are having. I'd rather have a lifetime warranty.
silverbullet830 is offline   Reply With Quote
Old 04-30-2014, 02:02 PM   #56
l3ighead
Scooby Newbie
 
Member#: 162552
Join Date: Oct 2007
Default

I would look into rockauto.com I ordered from them and replaced mine about 2 months no issues as of yet.
l3ighead is offline   Reply With Quote
Old 05-14-2014, 03:46 PM   #57
TuningIsLife
Scooby Newbie
 
Member#: 191380
Join Date: Oct 2008
Chapter/Region: MAIC
Vehicle:
2014 Jeep Wrangler
Hydro Blue

Default

Mine was groaning at about 60k. Replaced under my extended warranty.
TuningIsLife is offline   Reply With Quote
Old 05-22-2014, 06:32 PM   #58
Coldcat83
Scooby Newbie
 
Member#: 223799
Join Date: Sep 2009
Chapter/Region: South East
Location: Marietta, Ga.
Vehicle:
2009 WRX
Silver

Default

When you guys say your steering was whining was it the actual pump or the pulley freezing and causing the belt to screech? I replaced my pump a couple months ago because my pulley would just stop spinning and cause my belt to scream. Now the same problem is back, New fluid, No leaks (lines, Pump, Rack) anyone else experience this as opposed to the actual pump whine like the fluid is low? Any help is appreciated.
Coldcat83 is offline   Reply With Quote
Old 05-29-2014, 11:06 AM   #59
gsrcrxsi
Scooby Specialist
 
Member#: 236952
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Baltimore
Vehicle:
2010 WRX (SSM)
Stg "2+" 300hp/360trq

Default

i had this happen to me (pinion valve leak) at around 70 or 80k. i babied it for 10-20,000mi by just keeping the fluid topped off. replaced the pinion valve myself for about $250.
gsrcrxsi is offline   Reply With Quote
Old 06-27-2014, 12:44 AM   #60
coolrunningsmon
Scooby Newbie
 
Member#: 394713
Join Date: Jun 2014
Chapter/Region: E. Canada
Location: Toronto
Vehicle:
2011 STi
DGM

Default

Just dug up this thread. 2011 STi with 90k (Kms) and same issue. Out of standard warranty, but surprisingly the dealer goodwilled it with a new rack.
coolrunningsmon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 wrx power steering leak HELP vettedriver986 Factory 2.0L Turbo Powertrain 2 09-12-2010 10:53 PM
Power Steering Leak, where at those loose fittings? 275Performance Service & Maintenance 0 05-03-2003 11:46 PM
Power Steering Leaking!! waezsn Service & Maintenance 2 02-09-2003 06:12 AM
power steering leak thng Service & Maintenance 2 10-19-2002 04:04 PM


All times are GMT -4. The time now is 03:47 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.