Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-09-2006, 03:00 PM   #1
White 2.5rs
Scooby Guru
 
Member#: 39936
Join Date: Jul 2003
Vehicle:
99RS TWE&SCAT EJ257
Hydra+HMist+PPG+35R=DEATH

Default 1993 leg 2.2 wagon is getting horrible MPG

I bought the car used around 8 months ago. At the time, the guy told me that after a hot restart, the CEL would usually come on. I didn't think anything of it, figuring it was just a bad O2 sensor.

I am now getting 23-25 mpg...keep in mind 90% of that is freeway. I do drive in the wind, and in a hilly area, but that is horrible.

I went to Shucks today to have them pull the codes, but they couldn't find an appropriate OBD plug (is this car obd 2? seems pretty old to be...).

Anyone have any clue?

Main symptoms after hot restart:
-Idle is surgy, usually around 1200-1700.
-Super touchy gas pedal, it makes me look like a total noob when people are in the car and I shift.
-Horrible gas mileage

I've cleaned the air cleaner like 3 months ago, it might need it again, or perhaps a new one.

Anyone have any input?

Thanks
Alex
* Registered users of the site do not see these ads.
White 2.5rs is offline   Reply With Quote
Old 05-09-2006, 03:38 PM   #2
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

95+ Legacy is OBD II. You can check the cel yourself. Here is a good writeup from Legacy777 http://www.surrealmirage.com/subaru/engine.html
subiekid is offline   Reply With Quote
Old 05-09-2006, 04:06 PM   #3
White 2.5rs
Scooby Guru
 
Member#: 39936
Join Date: Jul 2003
Vehicle:
99RS TWE&SCAT EJ257
Hydra+HMist+PPG+35R=DEATH

Default

Im an idiot, thanks Dirty D
White 2.5rs is offline   Reply With Quote
Old 05-09-2006, 04:33 PM   #4
White 2.5rs
Scooby Guru
 
Member#: 39936
Join Date: Jul 2003
Vehicle:
99RS TWE&SCAT EJ257
Hydra+HMist+PPG+35R=DEATH

Default

Jesus 5 codes?

I think I'm going to reset the ECU and drive it for a while, because this is nuts.

Crank angle sensor
Ignition Switch
Knock Sensor <i can see its broken, physically!>
Air control valve
Canister Purge Solenoid

The only ones I think I need to fix are knock, air control, and the crank angle sensor.

Any inputs?
White 2.5rs is offline   Reply With Quote
Old 05-09-2006, 06:59 PM   #5
Wiscon_Mark
Scooby Guru
 
Member#: 94945
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Stevens Point, WI
Vehicle:
1995 Legacy OB 5MT
2003 Forester X 5MT

Default

ouch.
Wiscon_Mark is offline   Reply With Quote
Old 05-09-2006, 07:31 PM   #6
White 2.5rs
Scooby Guru
 
Member#: 39936
Join Date: Jul 2003
Vehicle:
99RS TWE&SCAT EJ257
Hydra+HMist+PPG+35R=DEATH

Default

lol, any others ?
White 2.5rs is offline   Reply With Quote
Old 05-09-2006, 08:14 PM   #7
Wiscon_Mark
Scooby Guru
 
Member#: 94945
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Stevens Point, WI
Vehicle:
1995 Legacy OB 5MT
2003 Forester X 5MT

Default

Well, I was thinking...sometimes when one thing goes wrong, it gets the ECU to think other stuff is wrong, even if it's not.

Try replacing the knock sensors first, then see how it pans out.
Wiscon_Mark is offline   Reply With Quote
Old 05-09-2006, 08:15 PM   #8
White 2.5rs
Scooby Guru
 
Member#: 39936
Join Date: Jul 2003
Vehicle:
99RS TWE&SCAT EJ257
Hydra+HMist+PPG+35R=DEATH

Default

Roger
thnx
White 2.5rs is offline   Reply With Quote
Old 05-09-2006, 08:58 PM   #9
MCarp22
Scooby Newbie
 
Member#: 102684
Join Date: Dec 2005
Location: Nashville, TN
Vehicle:
2013 Impreza
Deep Cherry

Default

The knock sensor is pretty important. When it's broken like that, your car could be very conservative with timing, and run a bit richer than it normally would to be "safe". That can lead to poorer mileage.
MCarp22 is offline   Reply With Quote
Old 05-09-2006, 09:54 PM   #10
White 2.5rs
Scooby Guru
 
Member#: 39936
Join Date: Jul 2003
Vehicle:
99RS TWE&SCAT EJ257
Hydra+HMist+PPG+35R=DEATH

Default

Do you guys know if any EJ series knock sensor will work?

Alex
White 2.5rs is offline   Reply With Quote
Old 05-10-2006, 06:11 PM   #11
Wiscon_Mark
Scooby Guru
 
Member#: 94945
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Stevens Point, WI
Vehicle:
1995 Legacy OB 5MT
2003 Forester X 5MT

Default

I would guess so. Any EJ22 sensor should.
Wiscon_Mark is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
horrible mpg question Brepic06 Service & Maintenance 9 11-26-2007 10:58 AM
my 2004 wrx wagon has utec .. i am getting 10~12 mpg.... imprezaBlue Engine Management & Tuning 4 12-28-2005 05:47 PM
My car is getting Horrible Gas milage - WHY? kusok Engine Management & Tuning 11 03-23-2005 11:33 PM
My car is getting horrible gas milage - why? kusok Service & Maintenance 1 03-21-2005 05:22 PM
Anybody getting >17 mpg. in Legacy Touring Wagon? ort5 Legacy Forum 13 02-17-2001 12:35 AM


All times are GMT -4. The time now is 01:06 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.