Welcome to the North American Subaru Impreza Owners Club Friday November 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Commercial ECU Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-12-2006, 08:43 AM   #1
sonic rx
Scooby Specialist
 
Member#: 33457
Join Date: Feb 2003
Chapter/Region: PRSIC
Location: 430 whp & 400 wtq 22 psi 93oct
Vehicle:
HAHA EVERYONE KNOWS
DYNO JET IS NOT REAL WHP

Default cold start rough idle with helix 820cc injectors

need some ecutek tuner advice . i have an 03 wrx with a 2.5l forged sti motor with cp pistons,wrx heads p&ped with helix cams and valvetrain. other mods are helix 820cc injectors ,aps 70mm cold air intake ,aps sr55,aps turbo inlet pipe and turbo back exhaust. i do have 2 cats in the down pipe. just breaking inn the motor . it know has 700 miles. my issue is when i start the car up it goes to high idle and about 30 secs after the idle starts bouncing up and down. the car has to be almost fully warm before i can even drive it otherwise it falls on it's face. and in colder weather 40 degrees it hardly wants to go to high idle on start up. it is only on starts after the car has cooled off completely 6- 8 hours. i am lookingfor some input. i know you can't solve but i am almost at wits end with this thing.
* Registered users of the site do not see these ads.
sonic rx is offline   Reply With Quote
Old 05-19-2006, 01:31 AM   #2
jaxscuby
Sammo Hung
Moderator
 
Member#: 10613
Join Date: Sep 2001
Chapter/Region: South East
Location: S Ga / Hell Rock
Vehicle:
2002 USDM WRX
WRB

Default

how close is the maf from the front of the turbo?
the maf should be approximately the same distance
from the turbo as stock.
jaxscuby is offline   Reply With Quote
Old 05-19-2006, 10:02 AM   #3
sonic rx
Scooby Specialist
 
Member#: 33457
Join Date: Feb 2003
Chapter/Region: PRSIC
Location: 430 whp & 400 wtq 22 psi 93oct
Vehicle:
HAHA EVERYONE KNOWS
DYNO JET IS NOT REAL WHP

Default

here is 2 pics one with the 2.0l motor,and an aps short ram intake. no coldstart issues



and here with the aps 70mm cold air intake on the 2.5l i also went from 650cc injectors to 820cc injectors. maf looks like it is the same spot though

sonic rx is offline   Reply With Quote
Old 05-24-2006, 11:45 AM   #4
tmarcel
Scooby Specialist
 
Member#: 7555
Join Date: Jun 2001
Chapter/Region: South East
Location: Charlotte NC
Default

You need to scale your MAF table in the low load cells. With Ecutek, you probably have to get reflashed for that. Also you probably need to change tip-in enrichment.
tmarcel is offline   Reply With Quote
Old 05-30-2006, 09:56 AM   #5
sonic rx
Scooby Specialist
 
Member#: 33457
Join Date: Feb 2003
Chapter/Region: PRSIC
Location: 430 whp & 400 wtq 22 psi 93oct
Vehicle:
HAHA EVERYONE KNOWS
DYNO JET IS NOT REAL WHP

Default

well i am giving my tuner the car from wed 31st to sat the 3rd . i am hoping the start issue will be cured by thursday. then i get tuned for power on the 3rd.i am just second guessing my choice in mods. i think the 70mm coldair is going top be a problem
sonic rx is offline   Reply With Quote
Old 05-30-2006, 10:11 AM   #6
tmarcel
Scooby Specialist
 
Member#: 7555
Join Date: Jun 2001
Chapter/Region: South East
Location: Charlotte NC
Default

It'll be fine. Just tune for it.
tmarcel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough cold starts and idle problems WorldRallyRedneck Service & Maintenance 6 03-25-2008 06:55 AM
18g with Helix 820cc injectors - any experience? FCmaniac Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 02-07-2008 04:41 PM
Helix 820cc injectors and UR 600cc injectors CHEAP!!! ilivas Engine/Power/Exhaust 24 06-08-2007 02:03 AM
cold engine Poor idle w. Helix injectors barry0164 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 01-02-2007 10:09 AM
Best injectors for STi in terms of idle/mileage/cold start when tuning with UTEC only RossWRX Engine Management & Tuning 1 12-26-2005 04:11 PM


All times are GMT -4. The time now is 10:54 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.