Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > UTEC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-31-2006, 10:56 PM   #1
Brady12
Scooby Specialist
 
Member#: 80923
Join Date: Feb 2005
Chapter/Region: MAIC
Location: Nova
Vehicle:
2008 FXT (XT Sport)
WRB

Default Stock snorkel and boost problems...

Hey guys..

I'm running a SZ55 set up on Alcohol @ 25psi.

I recently swapped out the black stock crinkle snorkel section of my intake for a Samco. Its conncected to a Smaco inlet and TurboXS intake.

She doesn't seem to be boosting very well in 1st and 2nd @ 22psi. Will get up to 25psi in 3rd and over.

I was told that with the Utec, you NEED to have that stock crinkel part for it to read right?? It creates some kind of vortex that the Utec reads, is this true

Let me know if anyone has had similar problems or suggestions

Thanx
* Registered users of the site do not see these ads.
Brady12 is offline   Reply With Quote
Old 08-01-2006, 07:18 AM   #2
hippy
Scooby Specialist
 
Member#: 36528
Join Date: May 2003
Location: florida
Vehicle:
2002 Impreza Wrx
Silver

Default

Not at far as I know. I'm pretty sure that the sensor which detects pressure doesn't take flow into account(since it's a pressure sensor and not a flow sensor). Ie-A "vortex" shouldn't make the boost any higher unless it was put there by moses.

peace
hippy is offline   Reply With Quote
Old 08-01-2006, 08:10 AM   #3
2phless
Scooby Specialist
 
Member#: 69343
Join Date: Aug 2004
Chapter/Region: South East
Location: 'tween Lewisville&Clemmons NC
Vehicle:
2000 nothing good
slow

Default

I've never heard of anything like that. The stock tube is supposed to flow well to a point. Perhaps the 55 is past that point.

What numbers were you hitting in 1st and 2nd with the "Smako" hose still installed? ( I like that typo... I'm calling them Smako from now on.)

I don't know of too many setups that'll make full boost in 1st or 2nd anyway, and with a big turbo like that... when is the soonest you can hit peak if you do a 3rd gear pull from a low rpm? (Not that it'll tell me much but I'm curious (<--> jealous) about the SZ55.
2phless is offline   Reply With Quote
Old 08-01-2006, 01:47 PM   #4
Brady12
Scooby Specialist
 
Member#: 80923
Join Date: Feb 2005
Chapter/Region: MAIC
Location: Nova
Vehicle:
2008 FXT (XT Sport)
WRB

Default

Well my Smako hose looks great much bigger, what I think is happening is that I'm redlining it and not getting up to boost, but ok after 3rd. This makes sence, from what your pointing out.

What I think i may need to do is reprogram it to enable a bigger reline past 7k. I'm not quite sure how to do that.

This info about the read from the rippled black stock portion was from a tune I had in the past @ TurboXS. I don't think it was the right assesement of the problem. It was later realized that my i/c was not big enough and flowing enough air for the SZ55

btw the Smako hoses are a bitch to fit and replace....

Thanks, going take er out for another spin see how she feels.
Brady12 is offline   Reply With Quote
Old 08-01-2006, 02:19 PM   #5
2phless
Scooby Specialist
 
Member#: 69343
Join Date: Aug 2004
Chapter/Region: South East
Location: 'tween Lewisville&Clemmons NC
Vehicle:
2000 nothing good
slow

Default

Quote:
Originally Posted by Brady12

What I think i may need to do is reprogram it to enable a bigger reline past 7k. I'm not quite sure how to do that.
The redline with the DBW throttle is stuck at 7k for a while. I don't think the new firmware will even help there. The Cobb tuning package might. But after splitting my motor in half twice now though... I don't wanna go over 7k.


Quote:
Originally Posted by Brady12

btw the Smako hoses are a bitch to fit and replace....
They all are. Getting rid of the stock fuel lines and re-routing the wiring under the intake somewhat helps. I just make my own intakes though. Cheaper, work great and have little chance of collapse.
2phless is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help w/16G and boost problems BrentS Factory 2.0L Turbo Powertrain 8 09-14-2006 06:05 PM
hesitation,rough idle, and boosting problem USMARINE24M Pre-2002 Factory Turbo Powertrain 3 06-11-2006 05:29 PM
EBC out and boost problems, help please Agkelos Factory 2.0L Turbo Powertrain 2 07-07-2005 11:13 PM
Acceleration and boost problems. jwease Factory 2.0L Turbo Powertrain 5 10-06-2004 12:44 AM
rough idle and boost problem 2002wrxstock Factory 2.0L Turbo Powertrain 2 04-19-2004 08:04 PM


All times are GMT -4. The time now is 12:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.