Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-09-2001, 10:58 PM   #1
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default Wire diagram for Field SFC

I just got my Field SFC, but now I need the wire diagram for it. I found a link that says what some of the wires are, but I still don't know how to install it. I need to know what more wires are for. Specifically which one goes to the MAF and which one goes to the ECU. I have done a search and all that comes up is Kartboy's SFC wire diagram, but that's for an Apex-i, not a Field.

Chad
93 1.8T
* Registered users of the site do not see these ads.
subachad is offline   Reply With Quote
Old 10-10-2001, 12:58 PM   #2
RallyNavvie
Scooby Specialist
 
Member#: 7113
Join Date: Jun 2001
Chapter/Region: TXIC
Location: Minnesotan in Texas
Vehicle:
2008 Spec B
DGM

Default

Hey where did you get that Field SFC from? I need to find a supplier for those as soon as possible. I haven't been able to find them anywhere.

And I had one of these installed in my car but other than the same diagrams you got (the one that says "refer to another sheet for wiring diagrams ) I don't have anything. I'm going to check with the guy who installed mine and see if he remembers anything.

But please let me know where you got that one from?
Thanks!!

~G
RallyNavvie is offline   Reply With Quote
Old 10-10-2001, 04:09 PM   #3
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

Would you mind telling me which wires you are using from the SFC. What colors? Specifically if you can see which wire is cut and goes to the SFC and which wire from the SFC continues that circut.

I bought the SFC from a fellow I-clubber used and I have some RS install instructions, but I have a 93 and it just says things like "put the O2 wire here" does not actually tell me what the color coded wires are.

If I could get a "the purple wire goes to the speedo pin on the ecu" type instruction set that would help me out the most.

I even have a diagram saying which taps on my ECU to use, only problem is WHICH WIRES FROM THE SFC??? gr, it's frustrating.

Chad
93 1.8T
subachad is offline   Reply With Quote
Old 10-10-2001, 08:31 PM   #4
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

ok. i took the time to look through the instructions. here is how i wired it up:

these wires you need to tap into the ecu. no cutting needed
red-power
black-ground
green-rpm
white-02
lightblue-speedsensor

these wires are the map sinsor wires. you will need to cut the ecu mapsensor wire.
orange-cut map wire going to the ecu side
brown-cut map wire going to the engine's side

purple,darkblue,and yellow are not used. tape these wires out of the way.


let me know if you need anymore help.
inpreza kid is offline   Reply With Quote
Old 10-11-2001, 11:42 AM   #5
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

Thank you SOOOOOOOOOOOOOOOOO much. I looked all over for that info. I'll be sure to post this on my site to, just to help any future Field SFC installs.

Looks like I have a little "project" tonight.

Chad
93 1.8T
subachad is offline   Reply With Quote
Old 10-29-2001, 03:37 PM   #6
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

GRRRRRRRRRRRRRRr

The SFC is not working. I'm pretty sure it's just not hooked up right. The O2 wire seems to be fine and it's getting power so all that's left is maybe the RPM signal is wrong.

I tapped into the RPM with a Fluke meter and it measures like 366 KHz which is the same as the Field says when it's in the RPM mode. All I get when I turn it on is a constant beep and a check engine light. What did I do wrong?

I used the above wire diagram and matched them up with the ECU pinout on the following link.

http://www.northursalia.com/index1.html

Any ideas on how I can fix this and maybe get it right?

Chad
93 1.8T
subachad is offline   Reply With Quote
Old 10-29-2001, 08:21 PM   #7
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

it sounds like a problem with the airsensor wire. did you check if it was going through the field hyper r with a voltmeter? also did you tap the power source from the ecu? if it doesn't turn on inline with the ecu the hyper r won't work for some reason. it took me awhile to figure how to get mine working right. did you check to make sure the dipswitch's are set right?
inpreza kid is offline   Reply With Quote
Old 10-30-2001, 11:30 AM   #8
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

What should the voltages be from the MAF?

Here's how I have the SFC hooked up.

orange - MAF side
brown - E30-5
light blue - E29-4
Red - E-29-10
black - grounded to the ecu cage
green - E29-3
White - E30-10

And remember, this is for a 93 Impreza. I double checked the o2 with a volt meter and it's right, I know the ground is good. The power only comes on when I turn the key to the on position since it's tapped into the ECU.

So, that leaves the wires tapping the MAF to check, the rpm signal I think is coming from the wrong place or maybe it's not the green wire? The speed signal might coming from the wrong place or is not the light blue wire.

Chad
93 1.8T
subachad is offline   Reply With Quote
Old 10-30-2001, 12:28 PM   #9
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

the rpm wire is the green one. the speed sensor is right too. i think your problem might be your speed sensor wire. the wires tapped do not modify the signal in any way so should not affect the ecu.
inpreza kid is offline   Reply With Quote
Old 10-30-2001, 01:04 PM   #10
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

Inpreza Kid, do you have the instructions from when you installed yours? I'm wondering which colors you plugged into which pins. I can check the ECU pinout with your car if you still have the info. I just want to see if the pin description matches what I have done as well.

Chad
93 1.8T
subachad is offline   Reply With Quote
Old 10-30-2001, 02:05 PM   #11
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

red-power B135 #7
black-ground ecu cover
green-rpm B134 #30
white-02 B136 #18
lightblue-speedsensor B 135 #24

orange-cut map wire going to the ecu side B136 #5
brown-cut map wire going to the engine's side B136 #5

ecu pinout info can be found at http://www.forcefed4.com/25rs/faq.php3 look under the MY2000-2001 info.
inpreza kid is offline   Reply With Quote
Old 10-30-2001, 02:50 PM   #12
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

OK I think I found it.

I have the brown wire going to the ECU and the Orange going to the MAF. I'll switch those two around today during my lunch and see if that fixes it. I'll letchya know.

Chad
93 1.8T
subachad is offline   Reply With Quote
Old 10-30-2001, 04:35 PM   #13
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

switched the two wires.

So now it doesn't just beep at me all the time and no check engine light. (got some funny looks in the parking lot)

Now I want to check the switches. In the bank of 8 switches, I have the #2 in the on position. In the bank of 4 switches, I have the #4 in the on position. All others are off.

I'm pretty sure even though the instructions say to do this, that it's wrong. For speed it just says 344 and the RPM is stuck at 7200 according to the SFC.

Almost there...

Chad
93 1.8T
subachad is offline   Reply With Quote
Old 10-30-2001, 07:23 PM   #14
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

so the sfc atleast somewhat works properly now? atleast thats a plus. ok you might want to double check the rpm and speen sensor wires to make sure you tapped the right ones. i'll check what my switches are set at right away and repost again. btw i don't think the correct switch settings are in the instructions.
inpreza kid is offline   Reply With Quote
Old 10-30-2001, 07:31 PM   #15
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

here are my switch settings

bank of 8:
1 up
2 down
3 up
4 up
5 up
6 up
7 up
8 up

bank of 4:
1 up
2 down
3 up
4 down

let me know if this works out for you.
inpreza kid is offline   Reply With Quote
Old 10-30-2001, 09:23 PM   #16
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

Changed the dip switches and I'm getting closer but it's still not there yet

It might just be a setting thing that I don't know what I'm doing, but I'm not sure.

The RPM's still only say 7300 and the speed is still stuck at 344???

I can get to a setting where I get an 8 or a 7 on the left and I can change the percentage of fuel. I know that's working because of the way my car runs when I do it. My air/fuel meter is fubared so I'm making a new one, in the mean time I'm going by the little lights on the SFC.

Any ideas what might be going on?

Inpreza, what do you usually see on the readout as you go through the screens?

Chad
93 1.8T
subachad is offline   Reply With Quote
Old 10-31-2001, 10:22 AM   #17
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

when i'm at the a/f ratio screen as i go through the rpms i can see the afc changing according to what rpm i'm at. i looked over your wiring diagrams. all the wires look corect. are you sure you tapped the right ones? i don't know if i'm right on this but rpm signal has nothing to do with the switch's. just the speed signal does.
inpreza kid is offline   Reply With Quote
Old 10-31-2001, 11:34 AM   #18
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

I'll double check the RPM and the speed signal in the ECU when I get back from Vegas. I really don't have any time tonight. Thanks a lot for your help, I'll post another update next week.

Chad
93 1.8T
subachad is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: Looking for wiring diagram for blitz r115 gauge! dacatz Electrical & Lighting 2 05-31-2006 01:41 AM
Looking for Wiring Diagram for a WRX 6-CD changer 16-pin connector ttl Car Audio, Video & Security 0 05-14-2004 05:19 PM
Need wiring info for Field SFC Hyper fuel computer dead-eye Electrical & Lighting 0 06-23-2003 07:14 PM
Wiring diagram for Feild SFC Eric Gagnon New England Impreza Club Forum -- NESIC 2 04-28-2001 05:42 AM
Need the wire connections for Field SFC Tony Technical Forum Archive 0 06-29-2000 08:31 AM


All times are GMT -4. The time now is 04:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.