Welcome to the North American Subaru Impreza Owners Club Wednesday September 3, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-10-2013, 05:05 PM   #776
Gamebay11
Scooby Newbie
 
Member#: 361945
Join Date: Jul 2013
Location: Racine, WI
Vehicle:
2011 Impreza WRX STi
Lightning Red

Default

I know im not posting a radio question just yet, but im trying to get a hold of SVXdc. Ive sent you 2 emails so far trying to order a headunit connector with no response. If oyu could get back to me I would appreciate it very much. With all the help you give out on here Im sure youre just extremely busy.

EDIT: Thank you. Will post many questions im sure when doing my install.
* Registered users of the site do not see these ads.

Last edited by Gamebay11; 07-10-2013 at 06:09 PM. Reason: Update post
Gamebay11 is offline   Reply With Quote
Old 07-14-2013, 12:30 AM   #777
SpicyPeaNut
Scooby Specialist
 
Member#: 43310
Join Date: Sep 2003
Chapter/Region: SCIC
Location: LA, California
Vehicle:
2013 Impreza WRX STI
World Rally Blue Pearl

Default

I figured I should actually post this here instead on the seperate thread.

So I bought my car with the factory navigation. Can I Swap the factory nav unit with the base model non-nav head unit without purchasing different harness plugs?

I want this:


To replace this:


Will this simply be a "unplug nav unit, plug in non-nav unit." quick and painless swap?
SpicyPeaNut is offline   Reply With Quote
Old 07-14-2013, 12:45 PM   #778
Mr5speed
Scooby Newbie
 
Member#: 268603
Join Date: Dec 2010
Location: Dover, DE
Vehicle:
2013 STI Hatch
WRBP

Default

I sent you a PM. Then found this. Didn't know if you are using factory or not.

Subwoofer/amplifier harness

H630SFG510

Regular head unit, no nav.
Mr5speed is offline   Reply With Quote
Old 07-14-2013, 04:54 PM   #779
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by SpicyPeaNut View Post
So I bought my car with the factory navigation. Can I Swap the factory nav unit with the base model non-nav head unit without purchasing different harness plugs?
...
Will this simply be a "unplug nav unit, plug in non-nav unit." quick and painless swap?
No. See my longer answer in your thread:
Base vs Nav, PnP Question
SVXdc is offline   Reply With Quote
Old 07-16-2013, 11:32 PM   #780
SpicyPeaNut
Scooby Specialist
 
Member#: 43310
Join Date: Sep 2003
Chapter/Region: SCIC
Location: LA, California
Vehicle:
2013 Impreza WRX STI
World Rally Blue Pearl

Default

Quote:
Originally Posted by SVXdc View Post

No. See my longer answer in your thread:
Base vs Nav, PnP Question
Svx, did you get my email
SpicyPeaNut is offline   Reply With Quote
Old 07-24-2013, 07:55 PM   #781
BURUTOO
Scooby Newbie
 
Member#: 349400
Join Date: Mar 2013
Location: Chicago, IL
Default

Quote:
Originally Posted by SpicyPeaNut View Post
I figured I should actually post this here instead on the seperate thread.

So I bought my car with the factory navigation. Can I Swap the factory nav unit with the base model non-nav head unit without purchasing different harness plugs?

I want this:


To replace this:


Will this simply be a "unplug nav unit, plug in non-nav unit." quick and painless swap?
I have not yet ordered my WRX so I am curious why you want to replace the optional oem nav system for the stock HU. is the oem nav that bad/not worth ordering?
BURUTOO is offline   Reply With Quote
Old 07-26-2013, 06:01 PM   #782
dallas4u
Scooby Newbie
 
Member#: 152999
Join Date: Jul 2007
Location: Portland, OR
Vehicle:
05 FXT MT
Silver

Default

Hey... hoping SVXdc or someone can help me with this. I apologize for asking for so much info, but...

I have an '05 Forester XT Premium with the sub. I bought a C123 headunit, the AUX cubby, and have the AUX cable for it. I'm still a little confused on what wires to tap in to and how to get the sub wired in to the AUX harness to get both working. Sorry, just having some trouble wrapping my brain around it. Do you mind helping at all?? Here is a post (by SVXdc) showing the pin outs of AUX cable and radio...

Post #10 from you here

I'm just not sure what wires to cut on which harness and where to splice them. Every time I start to think about it I get confused.

Thanks for any info you can give!!
dallas4u is offline   Reply With Quote
Old 07-26-2013, 07:40 PM   #783
dallas4u
Scooby Newbie
 
Member#: 152999
Join Date: Jul 2007
Location: Portland, OR
Vehicle:
05 FXT MT
Silver

Default

Quote:
Originally Posted by dallas4u View Post
Hey... hoping SVXdc or someone can help me with this. I apologize for asking for so much info, but...

I have an '05 Forester XT Premium with the sub. I bought a C123 headunit, the AUX cubby, and have the AUX cable for it. I'm still a little confused on what wires to tap in to and how to get the sub wired in to the AUX harness to get both working. Sorry, just having some trouble wrapping my brain around it. Do you mind helping at all?? Here is a post (by SVXdc) showing the pin outs of AUX cable and radio...

Post #10 from you here

I'm just not sure what wires to cut on which harness and where to splice them. Every time I start to think about it I get confused.

Thanks for any info you can give!!
Ok, well, I believe I'll be cutting the 8 pin plug (which should be 3 wires) from my current '05 harness, then need to somehow wire the two sub out wires to #4 and #8 on the new '08 plug on the AUX harness, then ground to chassis the third wire, but I'm not sure I know which are the two sub out wires on the '05 plug. I can't find a pin out for the '05 Forester with sub.
dallas4u is offline   Reply With Quote
Old 07-28-2013, 09:14 PM   #784
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by velcro View Post
I have an 07 Forester with the single CD ("type A") radio, with no AUX button. Is there any way to hack an AUX input (1/8" female) into this radio?
Thanks!
No easy way. There are a couple of threads that describe how to solder wires onto the HU's PC board, to connect your aux device into same place where the the CD, tape, or FM audio comes in. I'm fairly sure some were mentioned earlier in this thread.

It may be easier to find the double-DIN 2007 that has the aux input (nidek C-123 or C-124).
SVXdc is offline   Reply With Quote
Old 07-28-2013, 09:24 PM   #785
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by dallas4u View Post
I have an '05 Forester XT Premium with the sub. I bought a C123 headunit, the AUX cubby, and have the AUX cable for it. I'm still a little confused on what wires to tap in to and how to get the sub wired in to the AUX harness to get both working.
...
Quote:
Ok, well, I believe I'll be cutting the 8 pin plug (which should be 3 wires) from my current '05 harness, then need to somehow wire the two sub out wires to #4 and #8 on the new '08 plug on the AUX harness, then ground to chassis the third wire, but I'm not sure I know which are the two sub out wires on the '05 plug. I can't find a pin out for the '05 Forester with sub.
Your 2005 Forester's 8-pin harness only has 2 wires, for the subwoofer, on pins 4 and 8 (same locations and functions as on the C-123, except it's a different physical plug/socket).

I can provide a harness with the proper 8-pin connector to fit your 2005's factory harness. E-mail me for details.

You need to ground the new HU's aux enable pin (pin #6). If you're using an Impreza aux interconnect harness (intended for the C-124, which does not have the sub out), cut the wire going into the HU's pin #4, and ground the segment that goes to the aux pod. Use the other segment (going into the HU's pin #4) for your subwoofer.

You'll need to add a new wire to the HU's pin #8. I can supply a wire with the proper pin to snap into that plug. Again, e-mail me for details.

If you use an aux interconnect harness salvaged from a 2007-2008 Forester, it will have all of the pins wired that you need. You just need to connect the two subwoofer wires from your 2005's harness to pins 4 and 8 going into the HU, and ground a wire that goes to the aux pod's aux enable switch. There's a thread on the Forester forums which discusses that.
SVXdc is offline   Reply With Quote
Old 07-29-2013, 12:44 PM   #786
dallas4u
Scooby Newbie
 
Member#: 152999
Join Date: Jul 2007
Location: Portland, OR
Vehicle:
05 FXT MT
Silver

Default

Quote:
Originally Posted by SVXdc View Post
Your 2005 Forester's 8-pin harness only has 2 wires, for the subwoofer, on pins 4 and 8 (same locations and functions as on the C-123, except it's a different physical plug/socket).

I can provide a harness with the proper 8-pin connector to fit your 2005's factory harness. E-mail me for details.

You need to ground the new HU's aux enable pin (pin #6). If you're using an Impreza aux interconnect harness (intended for the C-124, which does not have the sub out), cut the wire going into the HU's pin #4, and ground the segment that goes to the aux pod. Use the other segment (going into the HU's pin #4) for your subwoofer.

You'll need to add a new wire to the HU's pin #8. I can supply a wire with the proper pin to snap into that plug. Again, e-mail me for details.

If you use an aux interconnect harness salvaged from a 2007-2008 Forester, it will have all of the pins wired that you need. You just need to connect the two subwoofer wires from your 2005's harness to pins 4 and 8 going into the HU, and ground a wire that goes to the aux pod's aux enable switch. There's a thread on the Forester forums which discusses that.
Sending you an email right now... thanks!
dallas4u is offline   Reply With Quote
Old 08-16-2013, 12:57 PM   #787
RyaanJaansen
Scooby Newbie
 
Member#: 283845
Join Date: May 2011
Default

While reinstalling the stock H/U, I disconnected the wrong section of wiring coming from my AUX/12V. Anyone have any ideas where this wire plugs into? I searched through the console and couldnt find anything.
RyaanJaansen is offline   Reply With Quote
Old 09-08-2013, 06:04 PM   #788
VASubaru
Scooby Newbie
 
Member#: 367801
Join Date: Sep 2013
Default Installation of Clarion CX501 in 2003 Outback Wagon

I want to replace the stock 6CD changer/radio in my 2003 Outback wagon with a Clarion CX501. I understand I will need a wiring harness but have been unable to figure out what to order. Do I need to order and installation kit as well? If so, does anyone know where I could find the correct installation kit? I also want to know how to find out where the antenna connection is on the stock head unit.
Many thanks to anyone who can help me out with this!

Last edited by VASubaru; 09-08-2013 at 06:53 PM. Reason: Spelling error
VASubaru is offline   Reply With Quote
Old 09-08-2013, 06:54 PM   #789
VASubaru
Scooby Newbie
 
Member#: 367801
Join Date: Sep 2013
Default

I found the answer to my antenna question here: http://forums.nasioc.com/forums/show...57030#poststop (SVXdc Antenna connection 04-10-2005, 01:32 AM).
VASubaru is offline   Reply With Quote
Old 09-08-2013, 07:54 PM   #790
Thekidboulay
Scooby Newbie
 
Member#: 364233
Join Date: Aug 2013
Default

What can fit a 2011 outback sport
Thekidboulay is offline   Reply With Quote
Old 09-10-2013, 12:10 AM   #791
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by RyaanJaansen View Post
While reinstalling the stock H/U, I disconnected the wrong section of wiring coming from my AUX/12V. Anyone have any ideas where this wire plugs into? I searched through the console and couldnt find anything.
What model and year car?

What do you mean by "the wrong section of wiring coming from my AUX/12V" ? Are you talking about the factory harnesses for the 3.5mm aux jack and accessory outlet ("cigarette lighter outlet") in the armrest center console? Where did you disconnect things? Can you post pictures?
SVXdc is offline   Reply With Quote
Old 09-10-2013, 12:20 AM   #792
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by Thekidboulay View Post
What can fit a 2011 outback sport
(I'm assuming you're talking about aftermarket head units).

Just about any double-DIN will fit. You'll need a dash kit for 2008-up Impreza/WRX/STi, or one of the JDM-style replacement bezels. See this post.

Any 2008-up Impreza, and 2009-up Forester OEM HU will fit. If your steering wheel includes the phone/Bluetooth buttons, you'll want to find an OEM HU from an Impreza or Forester that also had those buttons.
SVXdc is offline   Reply With Quote
Old 09-14-2013, 11:23 PM   #793
speedenthusiast1371
Scooby Newbie
 
Member#: 108140
Join Date: Feb 2006
Default

Those 20A backup light fuses will get you everytime

Last edited by speedenthusiast1371; 09-15-2013 at 01:22 AM. Reason: Figured it out
speedenthusiast1371 is offline   Reply With Quote
Old 09-15-2013, 03:21 AM   #794
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by speedenthusiast1371 View Post
I have a 13 Base WRX that I attempted to replace the stock HU in. I disconnected the battery, ...
Now after I connected all of the wires from my metra harness to the harness for my kenwood ddx 770, I went to connect it back to the car and now Im getting no power. I reconnected the stock radio and still nothing. No power.+ I've checked the fuses and and everything else.
Edited to:
Quote:
Those 20A backup light fuses will get you everytime
Yep, the fuse in the engine bay that powers the +12V Battery lead on the radio harness. Also powers the clock, courtesy lights, keyless entry, and more. Depending on year, it may be labeled "audio" or "backup". Backup means 'memory backup', not reverse gear lights.

You'll see that designation on HU service manuals, too -- "BU" or "B/U" for the pin with +12V Battery.
SVXdc is offline   Reply With Quote
Old 09-15-2013, 02:17 PM   #795
speedenthusiast1371
Scooby Newbie
 
Member#: 108140
Join Date: Feb 2006
Default

Thanks for the reply. I looked around for 45 min on my car trying to figure out what happened. I took more of the dash apart to see if one of the factory connections came loose before I started to look at the forums. In hindsight, I wish I would have seen your posts for the axxess... I said screw it and put it in a bag for the next time i feel like taking everything apart
speedenthusiast1371 is offline   Reply With Quote
Old 09-16-2013, 02:29 PM   #796
rlowery78
Scooby Newbie
 
Member#: 181076
Join Date: May 2008
Chapter/Region: South East
Vehicle:
2013 STI Hatch
WRB

Default

SVXdc - Need to order a harness, followed your instructions several days ago... Ready to pay you... Just need an invoice.

Sorry for placing junk in your informative thread.
rlowery78 is offline   Reply With Quote
Old 09-18-2013, 07:52 PM   #797
Seegy24
Scooby Newbie
 
Member#: 319426
Join Date: May 2012
Chapter/Region: MWSOC
Location: Dubuque
Vehicle:
2012 STi
Plasma blue pearl

Default

Ok Maybe someone can help (SVXdc) didn't see this thread when I ordered all the stuff to put a new head unit in my car. Everything is going good until I go to add the steering wheel controls. They want you to splice into the factory wiring and I don't want to do that. I know you sell the correct harness but didn't know that until now (already have other harness all wired in) I was wondering if you could point me in a direction to get the 3 pins I need and put them in my wiring harness. I cant seem to find them anywhere. Maybe easternbeaver, but I am also not sure which one I need for sure?
Seegy24 is offline   Reply With Quote
Old 09-25-2013, 12:37 AM   #798
ScoobieDriver87
Scooby Newbie
 
Member#: 367026
Join Date: Aug 2013
Location: SoCal
Vehicle:
2013 Impreza Sport
Pearl White

Default

I have a 2013 impreza sport and was wondering if I would be able to simply run my rcas into the back of my head unit or will I need to do something else.

I am a complete noob at this so any help will help greatly.
ScoobieDriver87 is offline   Reply With Quote
Old 09-25-2013, 11:09 PM   #799
Jmhm17
Scooby Newbie
 
Member#: 224097
Join Date: Sep 2009
Chapter/Region: NESIC
Location: Clinton, Ma.
Vehicle:
2012 WRX Hatch - DGM
Stage 1 - Tuned by Bren

Default

I have a 2012 base WRX and I understand I have pretty decent stock speakers they are kicker wozen cones with bigger magnets. I am looking to amp them with the stock head unit what is the max RMS wattage on the stock speakers? I do not want to blow them and replace them.

Also how do you get the signal from the stock HU to the amp?
Jmhm17 is offline   Reply With Quote
Old 09-26-2013, 12:09 AM   #800
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by Seegy24 View Post
I ... put a new head unit in my car. Everything is going good until I go to add the steering wheel controls. ...
I was wondering if you could point me in a direction to get the 3 pins I need [for the SWC wires] and put them in my wiring harness. I cant seem to find them anywhere. Maybe easternbeaver, but I am also not sure which one I need for sure?
I'm not aware of anyone selling the pins, other than the manufacturers (who require a minimum order of a reel of ~10,000 terminals).

The only place you'll find wires with the proper pins is by cannibalizing another of the same harness (and there are at least 3 different "flavors" out there, each with different, incompatible pins), or from me. Sorry.

If you order another significant item from me (such as an ASWC or an aux adapter harness), I can probably provide the 2 or 3 SWC wires with the proper pins to fit your harness.

For people who haven't ordered a harness yet, it's easier just to order a whole one from me.
SVXdc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stock head unit information -- pin-outs, aux inputs, and more SVXdc Car Audio, Video & Security 50 03-12-2014 11:27 AM
Question about factory head units nsnguyen Car Audio, Video & Security 7 04-30-2004 02:26 PM
Question about using head unit to power back speakers STI-o-MY Car Audio, Video & Security 0 12-01-2003 03:06 PM
question about my head unit creature546 Car Audio, Video & Security 1 10-03-2002 07:48 PM


All times are GMT -4. The time now is 04:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.