Welcome to the North American Subaru Impreza Owners Club Monday September 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-24-2006, 03:48 PM   #1
t3ch9
Scooby Newbie
 
Member#: 69549
Join Date: Sep 2004
Question Clutch making clicking / ticking type noise

So about a week and a half ago when driving home from work after turning on my car I noticed a clicking noise when I pressed down on the clutch. I thought it was a fluke at first so I pressed down on it again and heard the noise again. It went away after letting go of the clutch. I let car warm up on idle for a couple of minutes then pressed the clutch again and the sound was gone. I now notice this clicking / ticking noise every time I warm up or turn on my car. I goes away after a few minutes but I never had this issue before. I own a 2002 WRX with 62K miles. I just changed the tranny oil and checked the clutch fluid resovoir and its at full. Can anyone shed some light as to what's going on?

thanks!
* Registered users of the site do not see these ads.

Last edited by t3ch9; 05-24-2006 at 04:38 PM.
t3ch9 is offline   Reply With Quote
Old 05-25-2006, 02:21 PM   #2
STigmatizer
Scooby Newbie
 
Member#: 89924
Join Date: Jun 2005
Chapter/Region: MAIC
Vehicle:
2004 STi
Java Black

Default

The only thing that comes to mind is the throwout or pilot bearing. I can't remember which, but I had it replaced under warranty on my car. Somehow it rusted and galded.
STigmatizer is offline   Reply With Quote
Old 05-25-2006, 02:25 PM   #3
eddie1982
*** Banned ***
 
Member#: 114569
Join Date: May 2006
Location: Tuscaloosa,AL
Vehicle:
2004 JDM
Headache

Default

pilot bearing for sure
eddie1982 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clicking Solenoid Type Noise In Rf? 2002SUBIE Newbies & FAQs 5 08-30-2007 05:32 PM
99 GT LTD clutch pedal related thudding/ticking type noise Loktai Legacy Forum 2 03-11-2007 01:26 PM
clicking/ticking noises? kuuligan Newbies & FAQs 8 08-01-2006 03:10 PM
AVCR selenoid valve making loud ticking noise (problem or not) WRX-Blue-Mica Engine Management & Tuning 10 07-17-2005 06:18 PM
Clutch making a clicking noise popnfresh Transmission (AT/MT) & Driveline 0 06-10-2005 01:28 PM


All times are GMT -4. The time now is 04:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.