Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-26-2006, 12:10 AM   #1
verc
Scooby Specialist
 
Member#: 41754
Join Date: Aug 2003
Location: san ramon
Vehicle:
03 wrx
gt35r, 2.5L, meth

Default Strange power loss - compression is fine

couple days after I got tuned the car now accelerates like it's on 3 cylinders, or it's pulling a bunch of timing or something. It's really wierd since when I had a 2 liter sometimes this would happen and then the car would be fine later on.

No Cels, did a leakdown test and everything's fine, still reaches full boost at same rpms

The tune was almost certainly detonation free, any suggestions where to check next?
* Registered users of the site do not see these ads.
verc is offline   Reply With Quote
Old 05-26-2006, 12:34 AM   #2
RUrunning
Scooby Specialist
 
Member#: 68758
Join Date: Aug 2004
Chapter/Region: SCIC
Location: So Cal
Vehicle:
04 STi
R.I.P. AEROSIM

Default

Quote:
Originally Posted by verc
couple days after I got tuned the car now accelerates like it's on 3 cylinders, or it's pulling a bunch of timing or something. It's really wierd since when I had a 2 liter sometimes this would happen and then the car would be fine later on.

No Cels, did a leakdown test and everything's fine, still reaches full boost at same rpms

The tune was almost certainly detonation free, any suggestions where to check next?
did you just do the trickle down test or did you also get a proper compression test (removing spark plugs)?
RUrunning is offline   Reply With Quote
Old 05-26-2006, 12:37 AM   #3
RUrunning
Scooby Specialist
 
Member#: 68758
Join Date: Aug 2004
Chapter/Region: SCIC
Location: So Cal
Vehicle:
04 STi
R.I.P. AEROSIM

Default

oh, and i just had a thought. maybe this is going a bit too far, but did the weather suddenly get a lot hotter?
RUrunning is offline   Reply With Quote
Old 05-26-2006, 01:42 AM   #4
verc
Scooby Specialist
 
Member#: 41754
Join Date: Aug 2003
Location: san ramon
Vehicle:
03 wrx
gt35r, 2.5L, meth

Default

Quote:
Originally Posted by RUrunning
did you just do the trickle down test or did you also get a proper compression test (removing spark plugs)?

I did a full compression test - took out plugs and attached gauge.

Although the plugs did look at bit carbon-ized now that I think of it, and doing some more searching. I'm going to replace them to see if they are the culprit.

Any other ideas?
verc is offline   Reply With Quote
Old 05-26-2006, 02:18 AM   #5
flycaster
Scooby Specialist
 
Member#: 60142
Join Date: Apr 2004
Location: Bend, OR
Vehicle:
2011 WRX
Grey

Default

Quote:
Originally Posted by RUrunning
did you just do the trickle down test or did you also get a proper compression test (removing spark plugs)?
What's "the trickle down test?" That's a new one for me.
flycaster is offline   Reply With Quote
Old 05-26-2006, 05:36 AM   #6
RUrunning
Scooby Specialist
 
Member#: 68758
Join Date: Aug 2004
Chapter/Region: SCIC
Location: So Cal
Vehicle:
04 STi
R.I.P. AEROSIM

Default

Quote:
Originally Posted by flycaster
What's "the trickle down test?" That's a new one for me.
leakdown... tomatoe/shut-the-****-up

j/k
RUrunning is offline   Reply With Quote
Old 05-26-2006, 08:35 AM   #7
ride5000
Scooby Guru
 
Member#: 32792
Join Date: Feb 2003
Chapter/Region: NESIC
Location: lincoln, ri
Vehicle:
2003 GGA MBP
12.9 / 105+

Default

how do you do any compression/leakdown test WITHOUT removing plugs?
ride5000 is offline   Reply With Quote
Old 05-26-2006, 10:10 AM   #8
TheMadScientist
Scooby Guru
 
Member#: 23717
Join Date: Aug 2002
Chapter/Region: NESIC
Location: Beverly, MA
Vehicle:
2005 Big red

Default

Quote:
Originally Posted by ride5000
how do you do any compression/leakdown test WITHOUT removing plugs?



It works I tell ya.

TMS
TheMadScientist is offline   Reply With Quote
Old 05-26-2006, 10:26 AM   #9
arandomrat
Scooby Newbie
 
Member#: 115689
Join Date: May 2006
Default

You toss a few lead pellets into the intake and measure the thickness of them when they come out the tailpipe to check the compression without removing the plugs...



At least thats what i read on the internets
arandomrat is offline   Reply With Quote
Old 05-26-2006, 10:47 AM   #10
Tgui
Scooby Specialist
 
Member#: 44771
Join Date: Oct 2003
Default

Quote:
Originally Posted by arandomrat
You toss a few lead pellets into the intake and measure the thickness of them when they come out the tailpipe to check the compression without removing the plugs...



At least thats what i read on the internets
I've not "lol"ed froma Nasioc post in a long time.
Tgui is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power loss and strange chirp/cough jagatek Service & Maintenance 7 12-30-2008 08:19 PM
This is a dumb question...a simple yes or no is fine. ramrod Texas Impreza Club Forum -- TXIC 12 02-10-2008 11:14 PM
Strange Power loss Intermittent (today) P.J. Factory 2.5L Turbo Powertrain 2 01-04-2008 08:41 PM
Strange sudden power loss cordizzle Factory 2.0L Turbo Powertrain 13 11-29-2004 04:23 PM
Is loss of HP at the wheels a straight loss or is it a proportional loss? SC WRX Factory 2.0L Turbo Powertrain 5 07-09-2003 09:28 PM


All times are GMT -4. The time now is 07:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.