Welcome to the North American Subaru Impreza Owners Club Monday April 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-12-2000, 06:28 AM   #1
Peaty
Techno Sapien
Moderator
 
Member#: 449
Join Date: Oct 1999
Chapter/Region: MWSOC
Location: Lawrence, KS
Vehicle:
2010 Legacy 3.6R Lim
Azurite Blue Pearl

Question Dash Light [Q]

Last night I was driving the Legacy Outback (97') and I went to change the airflow of the heat. I noticed that the Icons on the HVAC controls aren't lit up but there is a little green light under each one that lights up when you push the button. Is this normal or are there lights in the buttons too. My wife usually drives the OB so I'm not sure. It was hard to figure out which button to push.

TIA

Peaty
* Registered users of the site do not see these ads.
Peaty is offline   Reply With Quote
Old 11-12-2000, 09:18 AM   #2
nuburu2
Scooby Specialist
 
Member#: 2609
Join Date: Oct 2000
Location: Roseville, Ca, USA
Vehicle:
98 BK-GT White
'97 SVX Ebony Pearl

Post

Peaty, Just went through this on my GT. Here's the step by step instructions I put together. Hope this helps!

Hey! Got those heater/AC lights working! Just wrote about 100 words to describe and my ham hands hit wrong key? Bam, gone!! So here goes again. If you got the 1st one, I'll recover here and finish. The lighting includes backlit mode select buttons, green lights showing selected mode below the buttons, lit slider control and fan switch and fan speed surround. All run off 3 bulbs! A/C has it's own inside the button (another story) First remove the Cup-holder (2 screws) and then pull out the top vents and surround. It just pulls out. Grasp it at the bottom of the vent openings and pull. This exposes the 4 screws holding Heat/AC module. It is held in then by temp control cable. This is held on by two locking rings, one on the cable end and the other pushed into a groove in the plastic, capturing the cable sheath. Both can be pulled out with long-nose pliers. Be patient and don't damage anything. I released park brake and sat on center console to get at it. Once loose take the module to workbench. The circuit board is covered by a sliding piece of black plastic which releases upward. The three bulbs turn 1/4 turn and pull out. There are 2 short and 1 long (lower right).The low center one may require you to release two catches and slide the assembly apart enough to get at it. (careful !) I would purchase all 3 (about 10-12 bucks) slip 'em in and put her back together. Wish someone had explained this to me first! The circuit board cover took a while to figure out! Dumb!! Good luck! Gives you nice opportunity to detail the buttons (pop off from bottom) and clean up the vents too! Happy GT'ing!! Glenn
nuburu2 is offline   Reply With Quote
Old 11-12-2000, 09:59 AM   #3
Peaty
Techno Sapien
Moderator
 
Member#: 449
Join Date: Oct 1999
Chapter/Region: MWSOC
Location: Lawrence, KS
Vehicle:
2010 Legacy 3.6R Lim
Azurite Blue Pearl

Thumbs up

Glenn,

Thanks a bunch, I did have it apart all the way to having the HVAC controls almost out. Just held on by the cable and then I wasn't sure the buttons themselves were supposed to be lit so I put it back together. Thought I better ask first.

Where did you get the bulbs? From the dealer or radio shack or something like that?

Thanks again,

Peaty
Peaty is offline   Reply With Quote
Old 11-12-2000, 10:44 AM   #4
nuburu2
Scooby Specialist
 
Member#: 2609
Join Date: Oct 2000
Location: Roseville, Ca, USA
Vehicle:
98 BK-GT White
'97 SVX Ebony Pearl

Post

Peaty, I didn't try anyone but the dealer. The bulbs were different than anything I'd seen before. They use some clear plastic semi-fiber optics to spread the light around to all the buttons, etc with so few bulbs. Kinda cool!!! I know what you mean about getting spooked. I took mine apart 3 times before I went far enough to get it done. Thought I could save others the trouble by telling them to pick up the bulbs first. I had the panel out and got an earful from the wife cuz her turn signals didn't work with the emergency flasher switch removed! doh! The Subie guy said these bulbs fail at about 3 years. The new bulbs look a little different (read improved?)
Glad I could help!
Glenn
nuburu2 is offline   Reply With Quote
Old 11-12-2000, 11:27 AM   #5
Peaty
Techno Sapien
Moderator
 
Member#: 449
Join Date: Oct 1999
Chapter/Region: MWSOC
Location: Lawrence, KS
Vehicle:
2010 Legacy 3.6R Lim
Azurite Blue Pearl

Post

Glenn,
That actually helped a lot. I went and took everything apart again and this time took out the button unit. I got to all the bulbs and see what you mean about them being funky. I sent an e-mail to Lisa (Sugar) at Troncalli along with some pics I took. Hopfully I'll have them soon. Once you've done it it's pretty simple to do.

The pics I have at this point are pretty lame but I plan on doing a whole DIY from start to finish after I get the bulbs. We can always put it on the AZScooby site for future reference.

Once again thanks,

Peaty
Peaty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
dash lights and tail lights quit working jasona Electrical & Lighting 3 03-21-2006 10:22 PM
Dash lights and Light pods?? 3BadHabbits Electrical & Lighting 4 11-06-2003 12:36 AM
NO dash lights and climate control lights blkbdrx Electrical & Lighting 4 10-24-2003 10:09 PM
What wire do I tap to make a neon light go on when I turn my dash lights on? NewbyScooby Electrical & Lighting 2 03-27-2003 07:44 PM


All times are GMT -4. The time now is 11:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.