Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-12-2006, 03:54 PM   #1
IwantONE
Scooby Newbie
 
Member#: 11720
Join Date: Oct 2001
Chapter/Region: TXIC
Location: Houston, TX
Default Boost issues or Gauge Issues?

I just installed a Defi Link electrical boost gauge in my 06 FXT. If the boost levels are the same in the 06 as they were in 04-05 then i'm seeing high boost. On wide open in 3rd or 4th the needle will sweep past 13 psi and fall back (very quickly) between 12 and 13 psi and then quiver at about 12.5. Could this be an issue with my install, my gauge, or my car? I tapped off of the BPV for the pressure sensor. The car has not been modified (except a prodrive muffler that i put on yesterday). I posted this on sf.org but i figured that i would get a faster respsonse here. Thanks for any help you can offer.

Alex
* Registered users of the site do not see these ads.
IwantONE is offline   Reply With Quote
Old 06-12-2006, 06:18 PM   #2
solarin006
Scooby Newbie
 
Member#: 109975
Join Date: Mar 2006
Chapter/Region: Tri-State
Location: Jersey
Default

To get rid of the quiver you need to install a restrictor in the line between your gauge and where you tapped into the BPV line. As far as the needle sweeping past 13 and dropping, that's your turbo spiking a little bit before the wastegate can catch up.
solarin006 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mechanical Issue or Tuning Issue? (Bucking/Hiccups) MConte05 Open Source Reflashes 6 06-30-2009 01:51 PM
boost gauge issue jcis2ez Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 02-28-2007 05:45 PM
Boost Gauge Issue (Need Help) MrWrxDc5 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 11 11-06-2006 12:52 AM
OEM boost gauge issue drkg Electrical & Lighting 9 03-26-2006 10:09 PM
Defi boost gauge issues smorris Electrical & Lighting 4 07-02-2003 08:14 PM


All times are GMT -4. The time now is 03:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.