Welcome to the North American Subaru Impreza Owners Club Thursday December 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-16-2006, 05:00 PM   #1
STIGuy116
Scooby Newbie
 
Member#: 87257
Join Date: May 2005
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 STI
OBP

Default check engine light question - 05 STi

I have an 05 sti with an 1820 turbo on it, APS inlet hose, power enterprise 850 cc injectors, walbro fuel pump, a utec and a tune from turboxs. My car dyno at 350lbs of torque and 327 whp. the check engine light is on from some type of slight misfires, i was told thats nothing to worry about. But my question is when im on the parkway getting on the car the check engine light tends to flash on then off???? What could that be, and how can i fix it!?!?!?!
* Registered users of the site do not see these ads.
STIGuy116 is offline   Reply With Quote
Old 06-16-2006, 05:09 PM   #2
drfrink24
Scooby Specialist
 
Member#: 36369
Join Date: May 2003
Chapter/Region: MWSOC
Location: Rochester, MN
Vehicle:
2004 WRX STi
Java Black

Default

Doesn't UTEC flash the CEL on knock events?
drfrink24 is offline   Reply With Quote
Old 06-16-2006, 05:48 PM   #3
STIGuy116
Scooby Newbie
 
Member#: 87257
Join Date: May 2005
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 STI
OBP

Default

i would assume it is a knock but how can i fix that? I've changed everything i was supposed to... occasionally it gets boost creep as well. when it doesn't creep i get the knock!
STIGuy116 is offline   Reply With Quote
Old 06-16-2006, 05:51 PM   #4
STimo
Scooby Specialist
 
Member#: 110273
Join Date: Mar 2006
Location: OC, California
Vehicle:
450 whp 30R STI
11.3@123, 10's a commin'

Default

I would stop getting on it until you have it figured out. It's not worth blowing the motor IMO.
STimo is offline   Reply With Quote
Old 06-16-2006, 11:25 PM   #5
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

I would take it back to TXS and have them look at it.
dexterous is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light question jlam86 Vancouver Impreza Club Forum -- VIC 7 11-28-2006 07:06 PM
2005 STi check engine light question STIGuy116 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 4 02-27-2006 08:40 PM
Check engine light question.... just one blunt Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 09-26-2004 09:04 PM
[B]Check Engine Light question regarding uppipe/downpipe[/B] Moshpit552 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 08-21-2004 03:36 AM
Check engine Light Question P1443 speedrkj Tri-State Area Forum 8 02-26-2003 08:39 PM


All times are GMT -4. The time now is 11:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.