Welcome to the North American Subaru Impreza Owners Club Tuesday September 27, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-03-2000, 11:58 AM   #1
iceman
Scooby Newbie
 
Member#: 1546
Join Date: May 2000
Location: New York
Vehicle:
95 Legacy L
Silver

Question a weird clunk noise for the front

hi
does anyone know anthing about a weird clunk noise that comes form the front end or a 93 legacy wagon? only happens when ur coming to a stop and you letting off the pedal a little.
* Registered users of the site do not see these ads.
iceman is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-03-2000, 01:07 PM   #2
Subie Gal
GC84Ever
Super Moderator
 
Member#: 301
Join Date: Sep 1999
Chapter/Region: NWIC
Location: WA
Vehicle:
1970 FF-1 & '70 Van
02 WRX/01 RS

Post

*check tires make sure they are secure

*check struts - make sure they are secure

*check brake calipers and pads

*check for rocks, sticks, etc.

just a thought

[This message has been edited by Subie Gal (edited November 03, 2000).]
Subie Gal is offline   Reply With Quote
Old 11-03-2000, 02:04 PM   #3
iceman
Scooby Newbie
 
Member#: 1546
Join Date: May 2000
Location: New York
Vehicle:
95 Legacy L
Silver

Post

thanx but i already checked all of that. do u think it could be the front end links or maybe a bad asb pump?
thanx ice
iceman is offline   Reply With Quote
Old 11-03-2000, 08:16 PM   #4
iceman
Scooby Newbie
 
Member#: 1546
Join Date: May 2000
Location: New York
Vehicle:
95 Legacy L
Silver

Post

any thoughts anyone?
ice
iceman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
weird clunking noise up front help please manimal15611 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 12-05-2005 11:29 PM
clunking noise from the front bobby d Brakes, Steering & Suspension 2 07-08-2005 10:39 AM
Weird clunking noise from the rear of the car. popnfresh Transmission (AT/MT) & Driveline 6 02-06-2005 05:13 PM
weird clunking noise from back right wrx_snobordr Service & Maintenance 18 05-19-2004 01:32 AM
brand new STI-WEIRD CLUNKING NOISE WRX2fast04 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 62 02-29-2004 10:30 AM

All times are GMT -4. The time now is 04:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.