Welcome to the North American Subaru Impreza Owners Club Sunday February 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-26-2006, 09:23 PM   #1
kenithzs
Scooby Newbie
 
Member#: 118270
Join Date: Jun 2006
Default Engine sputter at high RPM?

After about 15 minutes of hard driving at high RPM's, my '00 2.5RS will stall out at around 4500 RPM. It will then run as normal for a few minutes and then sputter out to the point where I cannot get it over 1500 RPM. Once the problem starts it snowballs until the car barely runs, Then I'll let it sit for about 5 minutes and it will run fine for five minutes and then sputter down to low RPM. The next day it will run strong for 15 minutes and then repeat. I pulled the code with the scantool program and it gave me P0463- Fuel Level Sensor High Input. The car was sitting still for a couple of years before I got it so I would not be surprised to find out that the sending units in the tank were hosed before this problem cropped up. If this error is the problem, could a fuel level sensor wreck things this badly?
Assuming that the error code was pre-existing, could these be the symptoms of a fuel pump/relay gone bad? I was thinking that perhaps it is extremly filthy injectors, but then again, why would it only occur after the car gets warmed up?



Thanks, any advice or info would be great.
-Ken
* Registered users of the site do not see these ads.
kenithzs is offline   Reply With Quote
Old 06-26-2006, 09:46 PM   #2
borgesxg
Scooby Newbie
 
Member#: 115643
Join Date: May 2006
Default

Do you know what the hardest this about beeing a Subaru owner is ?
borgesxg is offline   Reply With Quote
Old 06-27-2006, 02:18 PM   #3
bryan_johnson
Scooby Newbie
 
Member#: 78987
Join Date: Jan 2005
Default

bump for curiosity
bryan_johnson is offline   Reply With Quote
Old 06-27-2006, 03:03 PM   #4
Patrick L
Scooby Specialist
 
Member#: 634
Join Date: Dec 1999
Chapter/Region: TXIC
Location: Tulsa, OK
Vehicle:
2000 Impreza 2.5RS
Becasue ITS racecar

Default

Have you trying to get it up over 4500 by giving it full throotle.
I have had 2 front o2's(a/f meter) go bad without a CEL. They were giving a too low of a voltage reading. It's wold shudder like it wanted to stall out but once I got the RPM's up over 4000-4500 it would excelerate fine.
Patrick L is offline   Reply With Quote
Old 06-29-2006, 07:40 PM   #5
kenithzs
Scooby Newbie
 
Member#: 118270
Join Date: Jun 2006
Default

Quote:
Originally Posted by Top_Dog
Have you trying to get it up over 4500 by giving it full throotle.
I have had 2 front o2's(a/f meter) go bad without a CEL. They were giving a too low of a voltage reading. It's wold shudder like it wanted to stall out but once I got the RPM's up over 4000-4500 it would excelerate fine.
Yes when I give it full throttle it will not go above 1000 RPM, its almost as if the RPM govenor is kicking in about 7000 RPM's too soon.
kenithzs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine "stutters" at high rpm and after corners? Help please masterpickle Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 28 09-03-2008 03:57 PM
engine hesitates at high rpm tsukuba speed Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 12-24-2007 06:36 AM
2.2l Engine whistle at high RPM boyleia1 Normally Aspirated Powertrain 11 10-24-2007 05:37 PM
chek engine light at high rpm bigislandracing Off-Topic 18 07-19-2007 08:22 PM
engine sputtering at High Rev full throttle app. outback bosco Service & Maintenance 3 01-26-2002 11:17 PM


All times are GMT -4. The time now is 03:11 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.