Welcome to the North American Subaru Impreza Owners Club Friday July 31, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Commercial ECU Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-27-2006, 10:38 PM   #1
lukeskywrx
Scooby Specialist
 
Member#: 59837
Join Date: Apr 2004
Chapter/Region: SWIC
Location: Nor Cal
Vehicle:
2004 Spec-C Type RA
What MAF? -Speed Density!

Default Can Ecutek remove TGV CEL after sensor removal?

I would like to totaly remove the TGV system and not have to use the aps adaptor kit. But I never heard a firm response if a reflash can eliminate these engine codes.

thanks
Luke
* Registered users of the site do not see these ads.
lukeskywrx is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-28-2006, 02:06 PM   #2
Crawford/I-Speed
Vendor
 
Member#: 12347
Join Date: Nov 2001
Chapter/Region: SCIC
Location: Oceanside, CA
Vehicle:
ECU ReProgramming
Dynapack AWD Dyno

Default

Quote:
Originally Posted by lukeskywrx
I would like to totaly remove the TGV system and not have to use the aps adaptor kit. But I never heard a firm response if a reflash can eliminate these engine codes.

thanks
Luke
We have tested the standard method EcuTeK has given with no success. Currently on 02-05 WRX's we have not seen it work properly yet. EcuTeK has offered a new version of the TGV removal in the software which we are trying out.

Cheers,
Crawford Performance / I-Speed USA
Crawford/I-Speed is offline   Reply With Quote
Old 06-29-2006, 12:01 PM   #3
SloRice
Scooby Specialist
 
Member#: 44351
Join Date: Sep 2003
Chapter/Region: MWSOC
Location: Cincinnati, OH
Vehicle:
2004 Mitsubishi Evo
701whp 9.91@146

Default

The ECUtek flash I have from PDX removed the TGV code....at least I'm guessing it did because I don't have TGV's and I don't have a check engine light.
SloRice is offline   Reply With Quote
Old 06-29-2006, 12:20 PM   #4
Crawford/I-Speed
Vendor
 
Member#: 12347
Join Date: Nov 2001
Chapter/Region: SCIC
Location: Oceanside, CA
Vehicle:
ECU ReProgramming
Dynapack AWD Dyno

Default

Quote:
Originally Posted by SloRice
The ECUtek flash I have from PDX removed the TGV code....at least I'm guessing it did because I don't have TGV's and I don't have a check engine light.
That is probably because you have an USDM STi ECU which is much different from the 02-05 WRX ECU's. In conjunction with the EcuTeK software being different between the USDM STi's and 02-05 WRX's this changes how the TGV deletion works on the STi's and WRX's.

We have begun testing on the TGV removal with EcuTeK on the early USDM WRX's TGV CEL code removal (02-03 WRX's). So far it is moving in the right direction but we need to do some further testing to make sure it will work in most any situation.

Cheers,
Crawford Performance / I-Speed USA
Crawford/I-Speed is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL after AC removal? (P0186) twizzstyle Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 04-24-2009 04:10 PM
Uppipe EGT sensor removal. CEL fix? Gro Harlem Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 01-21-2009 01:53 PM
Anyone know where I can find a o2 sensor removal tool? sportz135 New England Impreza Club Forum -- NESIC 13 10-24-2005 11:43 AM
Can Ecutek remove tumbler delete CEL ? ronf Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 01-17-2005 02:26 PM
After Silencer Removal/Filter upgrade, CEL? FiSHxBFG Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 11-12-2001 11:16 PM


All times are GMT -4. The time now is 01:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.