Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-13-2006, 06:37 PM   #1
Subaru69
Scooby Newbie
 
Member#: 117676
Join Date: Jun 2006
Default 02 WRX Car Sputtering Issue

Hello.

I have a 02 WRX 5sp. First off, no modification at all.

I am currently having an issue whenever im driving in any gear usually between 2k-3.5k when i am cruising I can keep hearin the blow off valve randomly sputtering. Its as if i was venting to atmosphere randomly. Keep in mind this is a stock bov. When i am accelerating it happens in a stronger force as it will give a kick back dropping 100rpms and you can feel the jolt back.

I was thinking at first spark plugs one not firing, but that cant be true due to the fact that i am hearing the bov vent randomly.

As for the sound. Itsa typical vent type sound as you would hear during a shfit with a bov venting to atmosphere. However it does this while im in a gear say 3rd gear at 2.5k it sporaticly blows off and jolts the car.

I just got this car, i have had it for a week. Any Help would be appreciated. Thanks guys.
* Registered users of the site do not see these ads.
Subaru69 is offline   Reply With Quote
Old 07-13-2006, 07:08 PM   #2
MarylandEcstasy
Scooby Specialist
 
Member#: 103518
Join Date: Dec 2005
Chapter/Region: MAIC
Location: Brainchild Customs
Vehicle:
3d Custom Flyers
www.intuition-designs.com

Default

Mmm.. have you checked all connections, all bolts on the BPV, T fitting?? Does it sound like a monkey dying in your engine bay when you raise rpm levels?
MarylandEcstasy is offline   Reply With Quote
Old 07-13-2006, 07:22 PM   #3
Subaru69
Scooby Newbie
 
Member#: 117676
Join Date: Jun 2006
Default

haha nope.

It sounds like im intentionally blow ing off. Yet im staying at the same rpms.
Subaru69 is offline   Reply With Quote
Old 07-13-2006, 07:32 PM   #4
MarylandEcstasy
Scooby Specialist
 
Member#: 103518
Join Date: Dec 2005
Chapter/Region: MAIC
Location: Brainchild Customs
Vehicle:
3d Custom Flyers
www.intuition-designs.com

Default

Ok, I'm going to say that I've had this before once, and it was because I accidentally unhooked a vaccuum line from the BPV to the intake manifold when I installed my boost gauge. Doing so caused the car to make uneven rpm levels and made flutters, like what you hear from wastegate flutter. Again, check your lines..all of them..it has to be a leak of some sort...................if not, then go to your Subaru dealership and get your fix. Are ya still under warranty?
MarylandEcstasy is offline   Reply With Quote
Old 07-13-2006, 09:13 PM   #5
Subaru69
Scooby Newbie
 
Member#: 117676
Join Date: Jun 2006
Default

bought it last wednesday. Im under warranty for like 7 more weeks. Only BS is the fact they want a 100 dollar deductible.. even thought i bought it last week!
Subaru69 is offline   Reply With Quote
Old 07-13-2006, 09:19 PM   #6
AWD>FWD
Scooby Guru
 
Member#: 107027
Join Date: Feb 2006
Chapter/Region: NWIC
Location: Woodinville, WA
Vehicle:
2007 SWP WRX STi
w/MPS-built 2.34l

Default

Well, go in there and tell them you bought a car last week and you want to have a working car!
AWD>FWD is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
07 Sti Engine in 02 WRX cam sensor issue obrut Subaru Conversions 1 04-19-2009 12:06 AM
05 Cluster-02 WRX. LOTS of issues yankdanger Electrical & Lighting 5 02-19-2009 04:15 PM
02 WRX Clutch install issue Soulofdarkness Transmission (AT/MT) & Driveline 6 07-29-2008 05:24 PM
02 wrx alarm remote issues wrx=happy Car Audio, Video & Security 0 06-28-2007 09:35 PM
Need help with 02 WRX engine sputtering 95 avus blue Factory 2.0L Turbo Powertrain 1 09-09-2005 09:51 AM


All times are GMT -4. The time now is 10:21 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.