Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-13-2006, 11:19 AM   #1
subbieroo
Scooby Newbie
 
Member#: 120034
Join Date: Jul 2006
Default More EJ25 problems

So bought a RS with 2.5L EJ25. I was aware of the head gasket problems before hand and I actually bought it cheap with the blown driver side gasket since they didn't want to have it fixed and I knew I could do it myself. So, stripped the motor down, replaced the gaskets put everything back together. Everything is torqued right, no parts left over no bolts left over, wiring harness connections are all made. Go to turn it over last night and it just cranks. Will not fire up. Fuel Pump is connected i can here it turn on. Turned the key on and off a few times to prime the lines still won't start. Any ideas? I know its getting gas, I haven't checked to see if the pack is getting a spark down the wire yet though. Anything weird about this motor I should know that needs to been done after reinstalling everything that could be keeping it from starting? This is the first subaru I've owned so any help or tips would be great. Thanks.
Sam
* Registered users of the site do not see these ads.
subbieroo is offline   Reply With Quote
Old 07-13-2006, 12:01 PM   #2
Matt Monson
Scooby Guru
 
Member#: 832
Join Date: Jan 2000
Chapter/Region: RMIC
Location: Teh Ghetto Garage, CO
Vehicle:
99 2.5RS, '85 911
'73 914 and 2012 BRZ

Default

I am going to guess that you reversed the location of the fuel lines from the filter to the rails. That's the easiest thing to mix up...
Matt Monson is offline   Reply With Quote
Old 07-13-2006, 12:03 PM   #3
subbieroo
Scooby Newbie
 
Member#: 120034
Join Date: Jul 2006
Default

Anyone got a pic I use for reference where these are hooked up in the correct order?
subbieroo is offline   Reply With Quote
Old 07-13-2006, 12:03 PM   #4
Hayes
Scooby Specialist
 
Member#: 11808
Join Date: Oct 2001
Location: Cape Coral,FL
Default

Ignition is triggered by a sensor on one of the camshafts. Is it connected?
Hayes is offline   Reply With Quote
Old 07-13-2006, 12:08 PM   #5
subbieroo
Scooby Newbie
 
Member#: 120034
Join Date: Jul 2006
Default

yea driver side, its connected i checked that and the crank sensor right off
subbieroo is offline   Reply With Quote
Old 07-13-2006, 04:06 PM   #6
subbieroo
Scooby Newbie
 
Member#: 120034
Join Date: Jul 2006
Default

got it. return line and the other were mixed thanks guys!
subbieroo is offline   Reply With Quote
Old 07-14-2006, 02:48 AM   #7
Storm
Scooby Guru
 
Member#: 5218
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: SAUL'S Motorsports
Vehicle:
96L Most Over-
Developed Beater

Default

I love the easy fixes.....Congrats on a good cheap(er) car!!!

You'll love it even more if it snows where you are!
Jay
Storm is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What are typical ej25 problems? NapaBavarian Subaru Conversions 3 01-08-2010 03:11 AM
newby with strange ej25 problem porscharu Legacy Forum 5 07-01-2005 07:58 PM
98 RS Phase1 EJ25 problems?? ImprezaRSfan! Newbies & FAQs 1 11-10-2002 08:45 PM
more turbo problems kastle Normally Aspirated Powertrain 13 02-09-2001 09:34 AM
more alarm problems.... soob2k Car Audio, Video & Security 4 01-05-2001 02:16 PM


All times are GMT -4. The time now is 02:16 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.