Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-19-2010, 10:36 PM   #851
Mavrik
Scooby Guru
 
Member#: 90347
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2013 BRZ & Imp 2.5RS
Yamaha FZ8

Default

don't want your nuts falling off mid run eh brando? or unsecured load flying around.
* Registered users of the site do not see these ads.
Mavrik is offline   Reply With Quote
Old 03-19-2010, 10:37 PM   #852
Brando5185
Scooby Specialist
 
Member#: 189926
Join Date: Sep 2008
Chapter/Region: AKIC
Location: Goldsboro,NC
Vehicle:
HEMI Jeep GC
07 SV1K

Default

lol lol. I dont want anything flying out the window too early..... OK that might be enough from me haha
Brando5185 is offline   Reply With Quote
Old 03-26-2010, 01:28 PM   #853
Minimaul
Scooby Specialist
 
Member#: 116296
Join Date: May 2006
Chapter/Region: AKIC
Location: Hoth
Vehicle:
1997 M3
Black

Default

My new autocross "mod"

Minimaul is offline   Reply With Quote
Old 03-26-2010, 01:32 PM   #854
Mavrik
Scooby Guru
 
Member#: 90347
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2013 BRZ & Imp 2.5RS
Yamaha FZ8

Default

You get another car?
Mavrik is offline   Reply With Quote
Old 03-26-2010, 01:35 PM   #855
Minimaul
Scooby Specialist
 
Member#: 116296
Join Date: May 2006
Chapter/Region: AKIC
Location: Hoth
Vehicle:
1997 M3
Black

Default

Yup. I picked up Kent's `97 M3 last night.
Minimaul is offline   Reply With Quote
Old 03-26-2010, 01:49 PM   #856
06gtleg
Scooby Specialist
 
Member#: 197928
Join Date: Dec 2008
Chapter/Region: AKIC
Location: anchorage
Vehicle:
95 Outback
Green

Default

Dang!
06gtleg is offline   Reply With Quote
Old 03-26-2010, 02:30 PM   #857
Mavrik
Scooby Guru
 
Member#: 90347
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2013 BRZ & Imp 2.5RS
Yamaha FZ8

Default

Its all set to go eh?

gonna work on suspension bits this weekend I think
Mavrik is offline   Reply With Quote
Old 03-26-2010, 04:22 PM   #858
Minimaul
Scooby Specialist
 
Member#: 116296
Join Date: May 2006
Chapter/Region: AKIC
Location: Hoth
Vehicle:
1997 M3
Black

Default

oh yeah, the M3 is set up great. I still have the GTI with r-comps too, that I will also run here and there.
Minimaul is offline   Reply With Quote
Old 03-26-2010, 04:48 PM   #859
QwikEVO
Scooby Specialist
 
Member#: 44172
Join Date: Sep 2003
Chapter/Region: AKIC
Location: Eagle River, AK
Vehicle:
2003 Lancer Evo 8
Plasti-Dip is for TOOLS

Default

so what are you bringing to Tanacross?
QwikEVO is offline   Reply With Quote
Old 03-26-2010, 08:59 PM   #860
wrcRS
Scooby Specialist
 
Member#: 66632
Join Date: Jul 2004
Location: Anchorage Alaska
Vehicle:
2006 The Hurricane
Gray

Default

You will never want to autoX a front wheel drive car again after the Bimmer.
wrcRS is offline   Reply With Quote
Old 03-27-2010, 07:12 PM   #861
Getagrip
Scooby Specialist
 
Member#: 2045
Join Date: Aug 2000
Chapter/Region: South East
Location: Palm Harbor
Vehicle:
BRZ

Default

I got my same old stuff nothing new this year. I would like to get at least a rear swaybar and maybe front camber plates. But not gonna happen.
Getagrip is offline   Reply With Quote
Old 03-27-2010, 08:38 PM   #862
wrcRS
Scooby Specialist
 
Member#: 66632
Join Date: Jul 2004
Location: Anchorage Alaska
Vehicle:
2006 The Hurricane
Gray

Default

Im with Jake, we replace tires and brake pads...thats where all of our money goes.
wrcRS is offline   Reply With Quote
Old 03-28-2010, 07:26 PM   #863
Minimaul
Scooby Specialist
 
Member#: 116296
Join Date: May 2006
Chapter/Region: AKIC
Location: Hoth
Vehicle:
1997 M3
Black

Default

Quote:
Originally Posted by wrcRS View Post
You will never want to autoX a front wheel drive car again after the Bimmer.
I know. But at least I have some R-comps for the GTI cause that'll be some good motivation to drive that car.
Minimaul is offline   Reply With Quote
Old 03-29-2010, 02:38 AM   #864
AlaskaBimmer
Scooby Newbie
 
Member#: 150041
Join Date: May 2007
Chapter/Region: AKIC
Vehicle:
1981 BMW 323i Baur
98 BMW M3 Sedan

Default

at least I won't have to run with Damion in BSP I can run CS with mine (SCCA downgraded the E-36 M3 from BS to CS this year)....it's not nearly as well setup as his new toy....He'll get to run with you STI guys (if there are any ) that aren't in STU or SM....


If those R comps are 17s you could swap them on you M3 rims....245/40/17 is stock for the M3. But 225/45/17 was the stock front setup and what I run for winter tires.

I'll have no new mods on mine other than new rear brakes. I just spent $3600.00 to remove mold out my crawl space and another $3000.00 on fixing my fence before it fell over. Sometimes being my own landlord sucks.....at least I won't raise my rent because of this lol.
AlaskaBimmer is offline   Reply With Quote
Old 06-13-2010, 10:22 PM   #865
LiLpNoY
Scooby Specialist
 
Member#: 94836
Join Date: Aug 2005
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
2oo5 STi Aspen
2o12 PiLoT CherrY

Default

SO I notice that last run today, it felt like the tires were skipping?? Or like the wheels were loose or something? Any ideas? I torqued them before the run, and I dont do the wheel swapping yet.
LiLpNoY is offline   Reply With Quote
Old 06-13-2010, 11:09 PM   #866
Mavrik
Scooby Guru
 
Member#: 90347
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2013 BRZ & Imp 2.5RS
Yamaha FZ8

Default

tire temp maybe... or just your not used to going that fast LOL
Mavrik is offline   Reply With Quote
Old 06-13-2010, 11:48 PM   #867
LiLpNoY
Scooby Specialist
 
Member#: 94836
Join Date: Aug 2005
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
2oo5 STi Aspen
2o12 PiLoT CherrY

Default

Maybe. Lol I found that slowing down can equal faster times!
LiLpNoY is offline   Reply With Quote
Old 06-14-2010, 12:07 AM   #868
Mavrik
Scooby Guru
 
Member#: 90347
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2013 BRZ & Imp 2.5RS
Yamaha FZ8

Default

told ya man, smooth is fast
Mavrik is offline   Reply With Quote
Old 06-14-2010, 01:19 AM   #869
Nomadgene
Scooby Guru
 
Member#: 22923
Join Date: Aug 2002
Chapter/Region: International
Location: above 8000 rpm!
Vehicle:
2002 EJ207 V8 1.5xtr
TWIN-SCROLL Black Bugeye

Default

Lilpnoy, your tires sounded so strange out there. It was like they were sandpaper rubbing on wood out there on that degrading pavement. What was your tire pressure?
Nomadgene is offline   Reply With Quote
Old 06-14-2010, 02:34 AM   #870
LiLpNoY
Scooby Specialist
 
Member#: 94836
Join Date: Aug 2005
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
2oo5 STi Aspen
2o12 PiLoT CherrY

Default

I started off 36/36. I think I should run a higher pressure next time. Maybe 40/38 cold.
LiLpNoY is offline   Reply With Quote
Old 06-14-2010, 03:16 AM   #871
Mavrik
Scooby Guru
 
Member#: 90347
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2013 BRZ & Imp 2.5RS
Yamaha FZ8

Default

nah dude... you gotta run less... thats to much cold. start out low and let the air temps bring up your tire pressure. If you run to much air your tires will skip. let out some so they roll a little. more traction.
Mavrik is offline   Reply With Quote
Old 06-14-2010, 05:29 AM   #872
wrcRS
Scooby Specialist
 
Member#: 66632
Join Date: Jul 2004
Location: Anchorage Alaska
Vehicle:
2006 The Hurricane
Gray

Default

Quote:
Originally Posted by Mavrik View Post
nah dude... you gotta run less... thats to much cold. start out low and let the air temps bring up your tire pressure. If you run to much air your tires will skip. let out some so they roll a little. more traction.
I run about 35psi up front and 38-40psi in the rear in my Evo. 36psi doesn't seem to high to me?
wrcRS is offline   Reply With Quote
Old 06-14-2010, 10:20 AM   #873
Mavrik
Scooby Guru
 
Member#: 90347
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2013 BRZ & Imp 2.5RS
Yamaha FZ8

Default

40 front and 38 rear is way to high...
Mavrik is offline   Reply With Quote
Old 06-14-2010, 11:16 AM   #874
Nomadgene
Scooby Guru
 
Member#: 22923
Join Date: Aug 2002
Chapter/Region: International
Location: above 8000 rpm!
Vehicle:
2002 EJ207 V8 1.5xtr
TWIN-SCROLL Black Bugeye

Default

Yesterday I started off where wrcRS and LiLpNoy are mentioning, It worked but...not so great out on that course.

After a talk with Jammer, he told me he has run as low as 22 psi in the Starspecs at auto x and to look at what the sidewall is doing. He mentioned that he has had wear over the edge onto the sidewall using ALL of the tire. I grabbed a gauge and dropped the pressure down to 25 psi all the way around.

Last run was finally clean and smooth....result 58.7 something.

It was like velcro glue.


Still gotta get me some of them race tires though.
Nomadgene is offline   Reply With Quote
Old 06-14-2010, 01:10 PM   #875
LiLpNoY
Scooby Specialist
 
Member#: 94836
Join Date: Aug 2005
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
2oo5 STi Aspen
2o12 PiLoT CherrY

Default

Sounds like a plan. So 25psi hot?
LiLpNoY is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Teh official caravan to IAG Thread fastlanerex Mid Atlantic Impreza Club -- MAIC 18 02-21-2008 09:52 PM
Teh ***OFFICIAL*** OFFICIAL*** OT thread!!! wherethefmi Off-Topic 26 08-27-2007 12:34 PM
Teh official COM Sept. NHIS thread re92 New England Impreza Club Forum -- NESIC 52 09-17-2004 08:39 AM
teh OFFICIAL superbowl commercials thread rhdude Off-Topic 54 01-27-2003 12:05 PM
teh OFFICIAL find-Goosey-a-girl thread gongzero Off-Topic 28 01-20-2003 10:31 PM


All times are GMT -4. The time now is 07:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.