Welcome to the North American Subaru Impreza Owners Club Friday May 22, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-23-2006, 08:48 PM   #1
anzu
Scooby Newbie
 
Member#: 42154
Join Date: Aug 2003
Chapter/Region: MAIC
Location: Burke, VA
Vehicle:
2008 WRX STI
Aspen White

Question Pulled P2089 & P2093 CEL Codes

I recently pulled the following codes that is causing CEL and flashing cruise light:

P2089: OCV Solenoid Valve Signal A Circuit Short (Bank 1)
P2093: OCV Solenoid Valve Signal A Circuit Short (Bank 2)

I used the search here to find 2-3 posts that were very limited of information about this problem. There was one case of a loose ground (around the intake manifold) that caused the the code to be thrown and the 2-3 threads decided that was the problem based on the single post about these CEL's. I checked the grounding of my car and everything seems normal. Any suggestions besides bringing it to the dealer?

Thanks,
Andrew
* Registered users of the site do not see these ads.
anzu is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-30-2009, 05:53 PM   #2
metcalf164
Scooby Newbie
 
Member#: 186969
Join Date: Aug 2008
Chapter/Region: NESIC
Location: Waterboro, ME
Vehicle:
2006 sti
osb

Default

any updates on this I pulled the same codes today car runs fine but does not idle well and stalled once
metcalf164 is offline   Reply With Quote
Old 04-03-2009, 07:34 PM   #3
metcalf164
Scooby Newbie
 
Member#: 186969
Join Date: Aug 2008
Chapter/Region: NESIC
Location: Waterboro, ME
Vehicle:
2006 sti
osb

Default

fixed bad ground
metcalf164 is offline   Reply With Quote
Old 05-08-2009, 11:46 PM   #4
fzturbo
Scooby Newbie
 
Member#: 43482
Join Date: Sep 2003
Vehicle:
2004 JDM 2 litre STI
WRB

Default

sorry to bring up an old thread, but i'm getting the same codes mentioned in the first post.
Which ground wires should be checked in the intake manifold?


Thanks.
fzturbo is offline   Reply With Quote
Old 05-09-2009, 10:36 AM   #5
metcalf164
Scooby Newbie
 
Member#: 186969
Join Date: Aug 2008
Chapter/Region: NESIC
Location: Waterboro, ME
Vehicle:
2006 sti
osb

Default

On the top to each side they are large grounds
metcalf164 is offline   Reply With Quote
Old 11-04-2009, 02:00 PM   #6
wangan_x
Scooby Newbie
 
Member#: 63604
Join Date: Jun 2004
Chapter/Region: South East
Location: AL
Vehicle:
06 Subaru
STi

Default

thanks alot this took care of my codes
wangan_x is offline   Reply With Quote
Old 06-16-2011, 11:31 AM   #7
cha86
Scooby Specialist
 
Member#: 111048
Join Date: Mar 2006
Chapter/Region: MWSOC
Location: AA, Mi
Vehicle:
I <3 debt

Default

bump! had this issues. thanks for the quick fix.
cha86 is offline   Reply With Quote
Old 07-15-2011, 01:23 AM   #8
withaz
Scooby Newbie
 
Member#: 272112
Join Date: Jan 2011
Location: Oceanside, CA
Vehicle:
2006 STI
World Rally Blue Pearl

Default

thanks. had the same problem.
withaz is offline   Reply With Quote
Old 09-06-2014, 08:54 AM   #9
roadtrip1098
Scooby Newbie
 
Member#: 185688
Join Date: Jul 2008
Chapter/Region: NESIC
Location: Maine
Vehicle:
2006 STi
WR Blue

Default

NASIOC strikes again. Just changed injectors, did my scaling and all that but was having a nasty stumble on idle. I would lean all the way out, idle would drop to about 300, then it would catch itself (sometimes) and go very rich before leveling out and starting the process all over again. I was going nuts reading through data logs, checking and double checking my maps. Finally threw this code and low and behold, I had forgotten to tighten one of the ground wires.

The car is absolutely nuts now, logs look peachy, no crappy idle issues, rock solid AFR's.

This forum is a life saver. Even though I now feel like a n00b for missing tightening a friggin ground wire, thank you guys so much.

Also apologies if I just resurrected an ancient thread - answers are answers no matter how old.
roadtrip1098 is offline   Reply With Quote
Old 12-29-2014, 04:28 PM   #10
Luc
Scooby Newbie
 
Member#: 276589
Join Date: Mar 2011
Chapter/Region: NESIC
Location: CT
Vehicle:
2004 WRX STI
WRB

Default

This didnt work for me damn

Last edited by Luc; 12-29-2014 at 05:16 PM.
Luc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
check Engine Light !!! Need Help!!! P2089 & P2093 roccrew585 Service & Maintenance 2 01-20-2007 09:57 AM
HELP: where can I borrow a CEL code reader or get the code pulled for free? anonymous_wolf Vancouver Impreza Club Forum -- VIC 5 08-11-2005 01:40 AM
Anyone help in getting a CEL code pulled ? ZMANNH25rs New England Impreza Club Forum -- NESIC 5 02-27-2002 03:13 PM
Who can pull CEL codes? Concillian Bay Area Impreza Club Forum -- BAIC 31 01-21-2002 12:33 AM
pulling CEL code hp12c Bay Area Impreza Club Forum -- BAIC 4 12-10-2001 02:48 PM


All times are GMT -4. The time now is 11:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.