Welcome to the North American Subaru Impreza Owners Club Wednesday September 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-25-2006, 08:48 PM   #1
Damntree
Scooby Newbie
 
Member#: 88510
Join Date: Jun 2005
Have a Nice Day? 02 Sensor, Check Engine Light

I saw a few posts similar to this but I havent found a fix yet.

2000 RS
Borla Headers
Apexi Full Exhaust
Cold Air Intake


My check engine light has been on foever and a day. I couldnt get a state inspec with it on so I replaced my front O2 Sensor. The light stayed off for about a week and then came back on. I had already got the insepction so I just paid it no mind and went on my way. About 6 months later the car started idling up and down while parked or at a light and sometimes it would stall. Eventually it got to the point where it would bog down while driving on the highway and the car would jerk forward and then lose power, etc. It would also sometimes stall on the highway. So I took it into the dealer and they said it was the front O2 Sensor and the replaced it and the rough idle went away and also the check engine light went off.

Then 2 days later the check engine light is on again and has been on for the last 3 months. It runs fine and the light is now just a minor annoyance but I'm hoping I wont have to install an o2 sensor every year just to get my car inspected. Any ideas?
* Registered users of the site do not see these ads.
Damntree is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-26-2006, 10:49 AM   #2
Julian
Scooby Specialist
 
Member#: 1182
Join Date: Mar 2000
Location: Ventura, CA
Vehicle:
MY00 RS
BRP

Default

Get the OBD code. That'll give you a big hint as to what is wrong.

Or you could just throw parts at it.
Julian is offline   Reply With Quote
Old 07-27-2006, 02:36 PM   #3
kamil212
Scooby Guru
 
Member#: 90596
Join Date: Jul 2005
Chapter/Region: MWSOC
Location: NW Chicago
Vehicle:
2009 Scrambler
Bitches love Scramblers

Default

If it's the cat efficiency code then thats normal with borla headers. I got COBB CAI, Borla headers and a Stromung catback. My CEL used to come on while on longer trips but would stay off for weeks at a time once reset. I finally wrapped the headers and no CEL since then. I heard it only works for some people, others need the O2 wire fix.
kamil212 is offline   Reply With Quote
Old 07-27-2006, 03:52 PM   #4
Charge
Scooby Specialist
 
Member#: 3313
Join Date: Dec 2000
Chapter/Region: MWSOC
Location: Cincinnati
Default

Yep, we need to know which OBDII code it is, as there's more than one that points to the O2 sensor...but aren't exclusively just the O2 sensor.

Hit up an autozone and have them pull it for free, for you. We need the actual code # too...not their interpretation of what it means.
Charge is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light code P0137 o2 sensor circuit low voltage bank 1 sensor 2 duque Engine Management & Tuning 1 05-09-2010 01:43 AM
02 WRX check engine light blinking fast rallynutdon Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 07-13-2009 11:59 PM
O2 Sensor/Check Engine Light RSquared Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 2 09-27-2005 12:54 PM
Engine coolant temp sensor check engine light? rhdude Mid Atlantic Impreza Club -- MAIC 2 11-09-2002 02:42 AM


All times are GMT -4. The time now is 02:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.