Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-26-2006, 12:39 AM   #1
TheShadowWRX
Scooby Specialist
 
Member#: 11654
Join Date: Oct 2001
Location: DE, Happy Valley
Vehicle:
2002 WRX Sedan
WR Blue

Default Major Engine Problem

Hey,
My buddy was driving my WRX back from work... Stage 4+ with vf30 and all supporting mods... and he called me to say the car died and wouldn't start.
He said he was slowing down for train tracks and that the car stalled out and then wouldn't start back up.
When I got there, I tried to turn it on and it was making a terrible metal on metal screeching sound, everyone I've talked to thus far thinks its a rod.
Does anyone have any input on how this could have happened or why?
Also the sound is towards the back of the motor and in the center, but I only heard it for a few seconds because it sounds so terrible.

Anyone have any ideas?
I'm thinking of calling RalliSpec since they aren't too far away to see if they can have it towed to them and fix it or something.

Any input would be greatly appreciated.


Thanks,
Mike
* Registered users of the site do not see these ads.
TheShadowWRX is offline   Reply With Quote
Old 07-26-2006, 09:14 AM   #2
ride5000
Scooby Guru
 
Member#: 32792
Join Date: Feb 2003
Chapter/Region: NESIC
Location: lincoln, ri
Vehicle:
2003 GGA MBP
12.9 / 105+

Default

man, if i had a buck for every wrx/sti that was broken/cracked up/FUBARed while under the care of a "friend" i'd buy myself a mansion.

how could it happen? well IF its a bearing problem then oiling is the #1 issue. what can cause the issue is starvation from being underfilled or from high g sustained lateral loads, or from overrevving. detonation can also pound the oil film out of bearings which then are quite happy to spin in their seats.

when a car stalls out from bearing failure you've got a mess in the bottom end.
ride5000 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
major major install problems please have help me out! kefalonitis Factory 2.5L Turbo Powertrain 3 02-13-2009 12:08 PM
Major Engine Problem, help! popnGEAR Normally Aspirated Powertrain 6 10-03-2004 10:05 PM
Major Engine Problem, help! popnGEAR Factory 2.5L Turbo Powertrain 0 10-02-2004 02:38 PM
Major Engine Problem!!! mattjk Southern California Impreza Club Forum -- SCIC 38 10-04-2003 07:32 PM
Major Engine Problems! SubaruImpreza_power Newbies & FAQs 4 09-05-2003 03:09 PM


All times are GMT -4. The time now is 03:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.