Welcome to the North American Subaru Impreza Owners Club Saturday July 30, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-24-2006, 04:41 PM   #26
CE28
Scooby Newbie
 
Member#: 42174
Join Date: Aug 2003
Location: BC, Canada
Default

Checked bearing and seems fine...still looking for a solution.

Which one is the CV axle?

Thanks
* Registered users of the site do not see these ads.
CE28 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-24-2006, 06:30 PM   #27
WRX Shenanigans
Scooby Specialist
 
Member#: 101378
Join Date: Nov 2005
Chapter/Region: MAIC
Location: VA
Default

I am having the exact same problem. Can't figure it out. I accidentally opened a new thread (this one wasn't active at the time), here it is for my details:
http://forums.nasioc.com/forums/show....php?t=1075758

And to the poster above, I believe the cv axle is simply the axle....not sure though.

So I've heard thru this thread that it could be:
downpipe (just checked it though and it is fine)
rotate cv axle (how would I do that or check for that?)
wheel bearings (is this something a shade tree mechanic like me can do? and if not how much will that cost me?)
backing plates on brakes (what is the backing plate? are you talking about the shims on the pads? I just did my brakes this weekend. so where are we talking about?)

Thanks to those that helped and those that will help.
WRX Shenanigans is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loud Rubbing/Scraping on Left turns LickwidS0ap Newbies & FAQs 15 09-17-2008 10:38 AM
Rubbing noise only on right turns... WRX Shenanigans Newbies & FAQs 1 08-24-2006 06:18 PM
Rubbing Sound Making Left Turns InvertedB Mid Atlantic Impreza Club -- MAIC 7 08-24-2005 10:48 AM
Rubbing Sound Making Left Turns InvertedB Brakes, Steering & Suspension 1 08-23-2005 07:03 PM
grinding sound on right turns not CV joint MRF582 Brakes, Steering & Suspension 5 01-08-2005 09:20 PM

All times are GMT -4. The time now is 08:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.