Welcome to the North American Subaru Impreza Owners Club Thursday December 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-04-2006, 03:56 PM   #1
redhead09
Scooby Newbie
 
Member#: 121256
Join Date: Jul 2006
Default 04 sti messed up speedometer

my bro got an 04 sti, didn't have time to wash it by hand and it was dirty so he went through the carwash he picked the wash that also had underspray and the speedometer didn't work till the next day,he thought it had something to do with the underspray but then yesterday he went and got one withouth underspray and it it still isn't working. has this happened to any of you or have any idea wat is wrong?
* Registered users of the site do not see these ads.
redhead09 is offline   Reply With Quote
Old 08-04-2006, 04:36 PM   #2
joecerv
Scooby Specialist
 
Member#: 110459
Join Date: Mar 2006
Location: Somewhere in the DFW area
Vehicle:
2006 Impreza 2.5i
Steel gray metallic

Default

I am trying to read between the lines here.
Did the speedometer work when he got the car ?
Did not work after car wash and then worked again and then did not work ?

The speedometer cable could have come out.
Now, I am assuming worst case scenario here.
The previous owner took the cable out to keep the miles low.
Before selling car, puts cable back, not well I may say.
After taken ownership of car, cable comes out.
joecerv is offline   Reply With Quote
Old 08-10-2006, 05:49 PM   #3
redhead09
Scooby Newbie
 
Member#: 121256
Join Date: Jul 2006
Default

It worked when he got it, then about 2 weeks after he got it is wen he first took it to the car wash, right after the carwash it didn't work until the next day, but then after he got another carwash it finnally started working again but took about 3 days.
redhead09 is offline   Reply With Quote
Old 08-10-2006, 06:14 PM   #4
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

There is no speedometer cable. There is a vehicle speed sensor located on the transmission, the connector for it could be unplugged or loose or the wiring might be damaged. The sensor itself may also have failed.
Did the check engine light come on? It should if the speed signal from the sensor was interrupted.
There could also be a problem with the speedometer head in the dash, but that shouldn't be affected by external parts getting wet.
Mulder is offline   Reply With Quote
Old 08-10-2006, 06:42 PM   #5
overdose
Scooby Specialist
 
Member#: 46399
Join Date: Oct 2003
Chapter/Region: MWSOC
Location: Grand Rapids, MI
Vehicle:
0000 Knows nothing,
about nothing.

Default

my speedo has "tweaked out" once or twice, figure the speedo head though since no cel... but 60k bumper to bumper so if it craps out soa will be buying a new one
overdose is offline   Reply With Quote
Old 08-10-2006, 07:00 PM   #6
joecerv
Scooby Specialist
 
Member#: 110459
Join Date: Mar 2006
Location: Somewhere in the DFW area
Vehicle:
2006 Impreza 2.5i
Steel gray metallic

Default

My apoligies for using the wrong term (speedometer cable).
The sensor Mulder wrote about can be seen from the passenger side down toward the transmission.
It could be loose.
joecerv is offline   Reply With Quote
Old 08-10-2006, 07:03 PM   #7
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by overdose
my speedo has "tweaked out" once or twice, figure the speedo head though since no cel... but 60k bumper to bumper so if it craps out soa will be buying a new one

I don't know of a Subaru 60K bumper to bumper warranty, except the SAS warranty, but whether or not that would be covered depends on the plan you have. (It's still not a "bumper to bumper" warranty, technically)
RexyGirl is offline   Reply With Quote
Old 08-10-2006, 07:47 PM   #8
overdose
Scooby Specialist
 
Member#: 46399
Join Date: Oct 2003
Chapter/Region: MWSOC
Location: Grand Rapids, MI
Vehicle:
0000 Knows nothing,
about nothing.

Default

Quote:
Originally Posted by rexygirl
I don't know of a Subaru 60K bumper to bumper warranty, except the SAS warranty, but whether or not that would be covered depends on the plan you have. (It's still not a "bumper to bumper" warranty, technically)
subaru gold til 60k
overdose is offline   Reply With Quote
Old 08-10-2006, 10:16 PM   #9
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by overdose
subaru gold til 60k

Then, yes, it would be covered....as long as there wasn't an outside influence that cause it to go bad...

Your wear items still expire at 3/36, therefore making it not a bumper to bumper warranty (although you might already know that)
RexyGirl is offline   Reply With Quote
Old 08-11-2006, 02:36 AM   #10
redhead09
Scooby Newbie
 
Member#: 121256
Join Date: Jul 2006
Default

The Subaru dealership he bought it from told him they would fix a dent in the door but since he is only 19 they kinda have been saying we will call u but they nvr do so he had my dad call, so the told my dad they will fix the dent and have a look at the speedo also and get that fixed.
redhead09 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fs: 04 STI and up Utec sky_1982 Engine/Power/Exhaust 2 04-14-2007 07:02 PM
MY 2007 STI MESSED up nothingclub Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 14 03-29-2007 03:29 AM
04 STi Warranty up in 700miles. What turbo now? eviltwin Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 21 09-02-2006 05:11 PM
kids + block of wood + new STi = messed up new car SMOCKRAT Southern California Impreza Club Forum -- SCIC 42 11-06-2004 12:13 AM
messed up speedometer SpoolUp Electrical & Lighting 3 02-14-2004 10:53 PM


All times are GMT -4. The time now is 10:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.