Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-06-2006, 05:33 PM   #1
farrell
Scooby Specialist
 
Member#: 47746
Join Date: Nov 2003
Location: east stroudsburg PA
Vehicle:
2000 Impreza 2.5 RS
silverhorn

Default Engine Problems on 2.5rs

Sooo my car needs some maintance. It feels like its choking, for lack of a better word, when I step on the gas hard. Most of the time it feels like the engine kicks back in as I get into 5k RPM, but some times it works right all the way through. Also, it may just be a coincidence but my Air conditioner seems to go on and off as I drive, blowing normal air and then cold air, when its soposed to obviously be all cold.

Recently it has been brought to my attention that a cylinder may not be running and that I should check the spark plugs and spark plug wires. Does anyone have any other ideas on what I should check out for the first problem? I plan on checking that out on tuesday, but could that also be the problem for the AC? Thanks
* Registered users of the site do not see these ads.
farrell is offline   Reply With Quote
Old 08-06-2006, 05:46 PM   #2
hatchbuilder
Scooby Newbie
 
Member#: 102562
Join Date: Dec 2005
Default

It sounds like a bad ground maybe? Check all your electrical connections etc. Have you installed anything recectly that you had to unhook, splice into or otherwise take apart your engine bay for? That might be it. Check your plugs and wires too though but the presence of other electrical glitches makes me think there is something else going on.
hatchbuilder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wtb: ej25 sohc engine 99-01 2.5rs engine blueGC MWSOC Private Classifieds 0 04-05-2008 08:37 AM
Engine fan stoped wroking on 2.5rs mmmprza Engine Management & Tuning 2 11-11-2003 06:15 PM
engine fan stoped working on 2.5rs mmmprza Electrical & Lighting 1 11-10-2003 10:50 AM
2.0l Legacy Turbo Engine in a 2.5rs Audipwr1 Normally Aspirated with bolt-on Forced Induction Powertrain 9 09-27-2001 04:34 AM
engine swap into 2.5rs Silver_Fox General Forum Archive 1 03-26-2001 07:04 PM


All times are GMT -4. The time now is 11:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.