Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-07-2006, 06:30 PM   #1
EV1L JDI
Scooby Newbie
 
Member#: 71365
Join Date: Sep 2004
Chapter/Region: SWIC
Location: Rio Rico, Az
Vehicle:
2005 Impreza WRX STi
Black

Default EMERGENCY! Need some local info PLS!(CO)

Hey all,
I am visiting Aurora, CO from Arizona. Today while driving to lunch, I got a CEL and my "cruise control" light started flashing. I can also hear something that sounds like a vacuum leak, but only over ~3500 RPM. I am supposed to leave for AZ tomorrow, so I am not trying to diagnose or fix it myself, I just need to get the STi in somewhere ASAP and get it repaired.
I don't have any engine mods, but I do have suspension mods - so some extremely mod "unfriendly" dealers may not want to help me out. Any suggestions where to take it would be VERY appreciated.
I am near Parker and Quincy, so some place close would be nice, but it's driveable, so I can get pretty much anywhere in the Denver area!
Thanks
* Registered users of the site do not see these ads.

Last edited by EV1L JDI; 08-07-2006 at 06:51 PM.
EV1L JDI is offline   Reply With Quote
Old 08-07-2006, 06:56 PM   #2
Anub1s
Scooby Specialist
 
Member#: 81106
Join Date: Feb 2005
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2014 Baby Mobile
Whitey White

Default

Take it to a place to get the codes pulled, then post up the results. It sounds like there is a problem with either the intercooler piping or intake since it's an audible noise.
Anub1s is online now   Reply With Quote
Old 08-08-2006, 12:02 AM   #3
Helmut
Scooby Specialist
 
Member#: 85060
Join Date: Apr 2005
Chapter/Region: RMIC
Location: s.l.c. ut.
Vehicle:
0409 STI/ Fozzy XT
WRB/Dark Grey Metallic

Default

Also lots of the CO. guys/gals post up on www.awdpirates.net If you head over there this should be seen by tons of the locals and be able to help you out.
Helmut is offline   Reply With Quote
Old 08-08-2006, 12:14 AM   #4
EV1L JDI
Scooby Newbie
 
Member#: 71365
Join Date: Sep 2004
Chapter/Region: SWIC
Location: Rio Rico, Az
Vehicle:
2005 Impreza WRX STi
Black

Default

Thanks for the info, guys! I will be able to get the code read tomorrow and I should know more.
EV1L JDI is offline   Reply With Quote
Old 08-08-2006, 05:00 PM   #5
EV1L JDI
Scooby Newbie
 
Member#: 71365
Join Date: Sep 2004
Chapter/Region: SWIC
Location: Rio Rico, Az
Vehicle:
2005 Impreza WRX STi
Black

Default

Got the code today. Cam Shaft Position Detectors =/ I should have it fixed by this afternoon sometime. A curious side note, one of the "recommended" fixes was to drain the oil and run the engine for 5 min with no oil. I am not 100% convinced that is going to work, so I am just going to replace the sensors.
EV1L JDI is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
needing some help/info on local STi dye.sti New England Impreza Club Forum -- NESIC 31 10-19-2008 03:44 PM
Looking for some local info on Halifax 20oz Canada Region Forum 2 03-21-2006 12:53 PM
Visiting Chicago and UofI Urbana-Champaign, need some local info singincanary Mid West Subaru Owners Club Forum -- MWSOC 9 03-02-2005 02:42 PM
Harrisburg peeps - need some local info turboICE Tri-State Area Forum 3 12-03-2003 11:03 PM
Attn San Franciscans - Need Some Local Info MissDanz Off-Topic 16 11-03-2003 03:16 PM


All times are GMT -4. The time now is 02:31 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.