Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-12-2006, 01:03 PM   #1
vica153
Scooby Specialist
 
Member#: 76586
Join Date: Dec 2004
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
1994 GF6

Default Cruise control from 93 SS into 95L

I'm installing cruise crontol from a 93 SS into my car and I can't seem to find all the plugs for the module.

There are 2 white plugs on the module, and 2 small modules attached to it (4 prong, one black one blue)

I found the one of the whiteplugs and I think the black one. But I cant find the other white one. And I found a blue plu but its 2 wires not 4.

If I have to get the correct module for my wiring, will it work with a 93 SS engine?
* Registered users of the site do not see these ads.
vica153 is offline   Reply With Quote
Old 08-12-2006, 02:13 PM   #2
avk
Scooby Specialist
 
Member#: 17252
Join Date: Apr 2002
Chapter/Region: Tri-State
Location: NJ
Vehicle:
'06 WX8
59E

Default

A c.c. from Legacy will not plug in because it uses an electric vacuum pump while Impreza uses manifold vacuum (which might not work so well with forced induction). The wiring is not the same.
avk is offline   Reply With Quote
Old 08-12-2006, 03:47 PM   #3
vica153
Scooby Specialist
 
Member#: 76586
Join Date: Dec 2004
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
1994 GF6

Default

So if I buy the impreza module, would it work with the electric pump from the legacy?
vica153 is offline   Reply With Quote
Old 08-12-2006, 04:21 PM   #4
SubeTek
Scooby Specialist
 
Member#: 1714
Join Date: Jun 2000
Chapter/Region: RMIC
Location: Arvada,Co
Vehicle:
1999 RS-T COUPE
Black

Default

The impreza module will not work with the legacy parts--If i remember correctly, Subaru has some of the older cruise control kits on blowout sale. You might check with your local dealer on the price of the complete kit.
SubeTek is offline   Reply With Quote
Old 08-12-2006, 06:23 PM   #5
avk
Scooby Specialist
 
Member#: 17252
Join Date: Apr 2002
Chapter/Region: Tri-State
Location: NJ
Vehicle:
'06 WX8
59E

Default

Quote:
Originally Posted by vica153
So if I buy the impreza module, would it work with the electric pump from the legacy?
I suppose you can connect the vacuum hose from Impeza actuator to the pump instead of the manifold. The pump will have to be wired in to run when c.c.'s on which shouldn't be difficult. But if no one has tried it before, there might be a problem or two before you get it to work.
avk is offline   Reply With Quote
Old 08-12-2006, 07:30 PM   #6
vica153
Scooby Specialist
 
Member#: 76586
Join Date: Dec 2004
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
1994 GF6

Default

All the cruise control stuff I have is off the 93 SS. Actuator, pump, module, switch, control, cable...everything but the wiring.

So will the 95L module work with all that 93SS stuff?

Oh and what are the 2 things attached to the 93ss module?

Last edited by vica153; 08-12-2006 at 08:28 PM.
vica153 is offline   Reply With Quote
Old 08-12-2006, 10:56 PM   #7
avk
Scooby Specialist
 
Member#: 17252
Join Date: Apr 2002
Chapter/Region: Tri-State
Location: NJ
Vehicle:
'06 WX8
59E

Default

The Impreza has wiring for its own system (very cheap to buy now in a kit, as SubeTek said) and the plugs are not the same as you already know, except maybe for the dashboard switch. The controller uses a single white plug (16 or 20 pins, can't remember off-hand) and in the engine compartment there's a 4-wire plug for actuator, taped to the harness near AC lines at the bulkhead.
That plug is all you have to work with. You'd need to look at a Legacy wiring diagram to see if the plug can be used to run a Legacy pump and actuator. I have a '95 Impreza diagram, in case it might help. The two things you're asking about are probably relays, or relay sockets, although I haven't seen a control module from a Legacy. They aren't used on the Impreza.
avk is offline   Reply With Quote
Old 08-13-2006, 01:45 AM   #8
vica153
Scooby Specialist
 
Member#: 76586
Join Date: Dec 2004
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
1994 GF6

Default

I already wired the plug in the engine bay. The plugs are different, but the wires looked all the same.

Were all the 93-01 Manual trans module the same? Just 93-96? Or just 95?
vica153 is offline   Reply With Quote
Old 08-13-2006, 02:00 AM   #9
avk
Scooby Specialist
 
Member#: 17252
Join Date: Apr 2002
Chapter/Region: Tri-State
Location: NJ
Vehicle:
'06 WX8
59E

Default

So the wire colors were the same?
The modules for 1.8 l (like a '95 MT would have) were probably the same between years at least prior to 1996 but you'd need to check. If you want to buy new, it's much cheaper to get the whole kit.
avk is offline   Reply With Quote
Old 09-07-2006, 11:50 AM   #10
vica153
Scooby Specialist
 
Member#: 76586
Join Date: Dec 2004
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
1994 GF6

Default

Can you actually get the kit anywhere now?

And does anyone know if the module for my 95 would actually run the 93 SS pump and things correctly?
vica153 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hazards, horn, and cruise control dead on 93 Impreza Dodge Aries K Electrical & Lighting 1 11-05-2009 02:13 PM
EJ22T into 93 L Wagon 5spd/EJ22 into 93 SS auto swap. WagonMafia01 Subaru Conversions 13 06-01-2009 02:51 PM
diy! cruise control mod! 07 sti into 04 ts! antho! Electrical & Lighting 0 02-24-2009 12:48 AM
easiest way disconnecting cruise control cable from TB, cruise control removal 02-03 fastwrx25 Factory 2.0L Turbo Powertrain 4 09-21-2008 07:30 PM
Cruise Control into a 99 OBS 5mt???? opious Electrical & Lighting 5 07-05-2006 11:26 PM


All times are GMT -4. The time now is 06:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.