Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-17-2006, 01:35 AM   #1
Mountainer
Scooby Newbie
 
Member#: 108246
Join Date: Feb 2006
Vehicle:
2000 Legacy GT
Black

Question Front O2 Sensor install....

I have a '00 Legacy GT and I need to replace the fron 02 sensor. I know that I'm going to have to take the passenger front wheel and splash guard off to do this, but can anybody give me better instructions of getting to the sensor and stuff? And is a O2 sensor socket required to get this sensor out, or would it just make things easier? I'm planning on doing it tommorow morning because my car is running like crap with the dead sensor, so please someone help! Oh and will I need to reset my ECU to get everything working normal again?
* Registered users of the site do not see these ads.
Mountainer is offline   Reply With Quote
Old 08-17-2006, 10:06 AM   #2
C4NiNjA
Scooby Specialist
 
Member#: 91964
Join Date: Jul 2005
Chapter/Region: South East
Location: Sanford, NC
Vehicle:
2003 Impreza WRX WRB
349.9/354 Epic Tuned

Default

I just did this in my 03 WRX. If it is close to that, then it is right behind the splash guard and you can Borrow the correct tools from Advance Auto or Autozone. It took about 30 minutes. Just be careful when you reroute the 02 sensor wire so it stays away from the parts that get HOT.
C4NiNjA is offline   Reply With Quote
Old 08-17-2006, 10:53 AM   #3
Mountainer
Scooby Newbie
 
Member#: 108246
Join Date: Feb 2006
Vehicle:
2000 Legacy GT
Black

Default

Alright I just finished installing it actually, spent 20 minutes trying to break the previous sensor loose until I found some WD-40 lol. On my car, once I took the wheel off, you could see the sensor right in the middle of the Y pipe, so the splash guard thing didn't apply. Not too hard, alot easier than I thought it would be once I got the old one off. But my last question is, do I need to disconnect the battery now to reset the ECU or will it start working without the reset?
Mountainer is offline   Reply With Quote
Old 08-17-2006, 01:16 PM   #4
AJ711
Scooby Specialist
 
Member#: 6178
Join Date: Apr 2001
Chapter/Region: MAIC
Location: Singletracks
Vehicle:
98 GM67 + 03 SG6
2 whls > 4 whls

Default

It will start up just fine without an ECU reset. It may start a bit rough at first, but it'll even out after a minute or so.
AJ711 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Front O2 sensor vs Rear O2 sensor (MY00 RS) Jewbaru Service & Maintenance 3 07-29-2012 11:14 PM
need help with front O2 sensor install. kcismo New England Impreza Club Forum -- NESIC 1 12-19-2007 09:07 AM
Hesitation in 1st gear only -- after new front O2 sensor install? bpwatts UTEC 2 08-03-2007 02:15 AM
Front O2 sensor installation woes Charge Normally Aspirated Powertrain 6 07-07-2006 05:56 PM
Uppipe install - how to get front o2 sensor out? moby4dick Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 10-16-2005 07:59 PM


All times are GMT -4. The time now is 12:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.